Skip to content

← Actionable
High, CVSS 8.1Exploited · CISA KEV

Apache Struts vulnerable to remote command execution (RCE) due to improper input validation

CVE-2018-11776GHSA-cr6j-3jp9-rw65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.struts:struts2-core 2.5.17, 2.3.35), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2018-11776: 100.00% estimated exploitation activity in the next 30 days; percentile 99.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Struts contains a Remote Code Execution when using results with no namespace and it's upper actions have no or wildcard namespace. The same flaw exists when using a url tag with no value, action set, and it's upper actions have no or wildcard namespace.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cr6j-3jp9-rw65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-11776

Advisory: Apache Struts vulnerable to remote command execution (RCE) due to improper input validation
IDs: CVE-2018-11776, GHSA-cr6j-3jp9-rw65
Record: https://patchnext.com/advisories/cve-2018-11776 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.struts:struts2-core 2.5.17, 2.3.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.struts:struts2-core: affected >= 2.0.4, <= 2.3.34; >= 2.5, <= 2.5.16; fixed in 2.5.17, 2.3.35

## Suggested inspection (read-only)
- Maven org.apache.struts:struts2-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.struts:struts2-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2018-11776 to the Known Exploited Vulnerabilities catalog on 2021-11-03.)
- Verified: https://github.com/advisories/GHSA-cr6j-3jp9-rw65 (GitHub-reviewed advisory GHSA-cr6j-3jp9-rw65 lists affected ranges: Maven org.apache.struts:struts2-core >=2.0.4 =2.5 <=2.5.16)

Commands are suggestions: review each one before running it.

Loading voting…