Skip to content

← Public intelligence

Maven package

org.apache.spark:spark-core_2.11

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7MavenAmendedPublished

    Sensitive data written to disk unencrypted in Spark

    CVE-2019-10099 · GHSA-fp5j-3fpf-mhj5

    Affected
    • Maven org.apache.spark:spark-core_2.11 < 2.3.3
    Fixed in
    2.3.3· Vendor fix available
    Issue
    Prior to Spark 2.3.3, in certain situations Spark would write user data to local disk unencrypted, even if spark.io.encryption.enabled=true. This includes cached blocks that are fetched to disk (controlled by spark.maxRemoteBlockSizeFetchToMem); in SparkR, using parallelize; in Pyspark, using broadcast and parallelize; and use of python udfs.

    Recommended action: Upgrade to 2.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.0MavenAmendedPublished

    Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark

    CVE-2018-1334 · GHSA-6mqq-8r44-vmjc

    Affected
    • Maven org.apache.spark:spark-core_2.11 >= 1.0.0, < 2.1.3; >= 2.2.0, < 2.2.2; >= 2.3.0, <= 2.3.0
    Fixed in
    2.1.32.2.22.3.1· Vendor fix available
    Issue
    In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

    Recommended action: Upgrade to 2.3.1, 2.2.2 or 2.1.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark via crafted URL

    CVE-2018-8024 · GHSA-8cw6-5qvp-q3wj

    Affected
    • Maven org.apache.spark:spark-core_2.11 >= 2.1.0, < 2.1.3; >= 2.2.0, < 2.2.2; >= 2.3.0, <= 2.3.0
    Fixed in
    2.1.32.2.22.3.1· Vendor fix available
    Issue
    In Apache Spark 2.1.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, it's possible for a malicious user to construct a URL pointing to a Spark cluster's UI's job and stage info pages, and if a user can be tricked into accessing the URL, can be used to cause script to execute and expose information from the user's view of the Spark UI. While some browsers like recent versions of Chrome and Safari are able to block this type of attack, current versions of Firefox (and possibly others) do not.

    Recommended action: Upgrade to 2.3.1, 2.2.2 or 2.1.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.5MavenAmendedPublished

    Apache Spark Deserialization of Untrusted Data vulnerability

    CVE-2017-12612 · GHSA-8rhc-48pp-52gr

    Affected
    • Maven org.apache.spark:spark-core_2.11 < 2.1.2
    Fixed in
    2.1.2· Vendor fix available
    Issue
    In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.

    Recommended action: Upgrade to 2.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 6.1MavenPublished

    Moderate severity vulnerability that affects org.apache.spark:spark-core_2.10 and org.apache.spark:spark-core_2.11

    CVE-2017-7678 · GHSA-r34r-f84j-5x4x

    Affected
    • Maven org.apache.spark:spark-core_2.11 < 2.2.0
    Fixed in
    2.2.0· Vendor fix available
    Issue
    In Apache Spark before 2.2.0, it is possible for an attacker to take advantage of a user's trust in the server to trick them into visiting a link that points to a shared Spark cluster and submits data including MHTML to the Spark master, or history server. This data, which could contain a script, would then be reflected back to the user and could be evaluated and executed by MS Windows-based clients. It is not an attack on Spark itself, but on the user, who may then execute the script inadvertently when viewing elements of the Spark web UIs.

    Recommended action: Upgrade to 2.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →