Sensitive data written to disk unencrypted in Spark
CVE-2019-10099GHSA-fp5j-3fpf-mhj5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.spark:spark-core_2.11 2.3.3; pyspark 2.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.spark:spark-core_2.11
- Affected
- < 2.3.3
- Fixed in
- 2.3.3
PyPI pyspark
- Affected
- < 2.3.3
- Fixed in
- 2.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fp5j-3fpf-mhj5 lists affected ranges: Maven org.apache.spark:spark-core_2.11 >=0 =0 <2.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fp5j-3fpf-mhj5 lists affected ranges: Maven org.apache.spark:spark-core_2.11 >=0 =0 <2.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2019-10099: 1.30% estimated exploitation activity in the next 30 days; percentile 70.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Prior to Spark 2.3.3, in certain situations Spark would write user data to local disk unencrypted, even if spark.io.encryption.enabled=true. This includes cached blocks that are fetched to disk (controlled by spark.maxRemoteBlockSizeFetchToMem); in SparkR, using parallelize; in Pyspark, using broadcast and parallelize; and use of python udfs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fp5j-3fpf-mhj5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fp5j-3fpf-mhj5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10099 Advisory: Sensitive data written to disk unencrypted in Spark IDs: CVE-2019-10099, GHSA-fp5j-3fpf-mhj5 Record: https://patchnext.com/advisories/cve-2019-10099 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.spark:spark-core_2.11 2.3.3; pyspark 2.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.spark:spark-core_2.11: affected < 2.3.3; fixed in 2.3.3 - PyPI pyspark: affected < 2.3.3; fixed in 2.3.3 ## Suggested inspection (read-only) - Maven org.apache.spark:spark-core_2.11: check the installed version with your package manager. - `python -m pip show pyspark`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.spark:spark-core_2.11, pyspark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fp5j-3fpf-mhj5 (OSV record GHSA-fp5j-3fpf-mhj5 lists affected ranges: Maven org.apache.spark:spark-core_2.11 >=0 =0 <2.3.3 (fixed)) - Verified: https://github.com/advisories/GHSA-fp5j-3fpf-mhj5 (GitHub-reviewed advisory GHSA-fp5j-3fpf-mhj5 lists affected ranges: Maven org.apache.spark:spark-core_2.11 >=0 =0 <2.3.3) Commands are suggestions: review each one before running it.
Loading voting…