Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark
CVE-2018-1334GHSA-6mqq-8r44-vmjc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.spark:spark-core_2.11 2.3.1, 2.2.2, 2.1.3; pyspark 2.2.2, 2.1.3; org.apache.spark:spark-core_2.10 2.2.2, 2.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.spark:spark-core_2.11
- Affected
- >= 1.0.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, <= 2.3.0
- Fixed in
- 2.1.3, 2.2.2, 2.3.1
PyPI pyspark
- Affected
- >= 2.2.0, < 2.2.2< 2.1.3
- Fixed in
- 2.1.3, 2.2.2
Maven org.apache.spark:spark-core_2.10
- Affected
- >= 1.0.0, < 2.1.3>= 2.2.0, < 2.2.2
- Fixed in
- 2.1.3, 2.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6mqq-8r44-vmjc lists affected ranges: Maven org.apache.spark:spark-core_2.10 >=1.0.0 =2.2.0 =1.0.0 =2.2.0 =2.3.0 =2.2.0 =0 <2.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6mqq-8r44-vmjc lists affected ranges: Maven org.apache.spark:spark-core_2.10 >=1.0.0 =2.2.0 =1.0.0 =2.2.0 =2.3.0 =2.2.0 =0 <2.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2018-1334: 0.51% estimated exploitation activity in the next 30 days; percentile 43.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6mqq-8r44-vmjc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6mqq-8r44-vmjc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1334 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark IDs: CVE-2018-1334, GHSA-6mqq-8r44-vmjc Record: https://patchnext.com/advisories/cve-2018-1334 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.spark:spark-core_2.11 2.3.1, 2.2.2, 2.1.3; pyspark 2.2.2, 2.1.3; org.apache.spark:spark-core_2.10 2.2.2, 2.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.spark:spark-core_2.11: affected >= 1.0.0, < 2.1.3; >= 2.2.0, < 2.2.2; >= 2.3.0, <= 2.3.0; fixed in 2.1.3, 2.2.2, 2.3.1 - PyPI pyspark: affected >= 2.2.0, < 2.2.2; < 2.1.3; fixed in 2.1.3, 2.2.2 - Maven org.apache.spark:spark-core_2.10: affected >= 1.0.0, < 2.1.3; >= 2.2.0, < 2.2.2; fixed in 2.1.3, 2.2.2 ## Suggested inspection (read-only) - Maven org.apache.spark:spark-core_2.11: check the installed version with your package manager. - `python -m pip show pyspark`: prints the installed version. Run with the environment that serves production active. - Maven org.apache.spark:spark-core_2.10: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.spark:spark-core_2.11, pyspark, org.apache.spark:spark-core_2.10. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6mqq-8r44-vmjc (OSV record GHSA-6mqq-8r44-vmjc lists affected ranges: Maven org.apache.spark:spark-core_2.10 >=1.0.0 =2.2.0 =1.0.0 =2.2.0 =2.3.0 =2.2.0 =0 <2.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-6mqq-8r44-vmjc (GitHub-reviewed advisory GHSA-6mqq-8r44-vmjc lists affected ranges: Maven org.apache.spark:spark-core_2.10 >=1.0.0 =2.2.0 =1.0.0 =2.2.0 =2.3.0 =2.2.0 =0 <2.1.3) Commands are suggestions: review each one before running it.
Loading voting…