Skip to content

← Public intelligence

Maven package

org.apache.kylin:kylin-core-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Apache Kylin Files or Directories Accessible to External Parties

    CVE-2025-61734 · GHSA-p86w-w5rh-m3hx

    Affected
    • Maven org.apache.kylin:kylin-core-common >= 4.0.0, < 5.0.3
    Fixed in
    5.0.3· Vendor fix available
    Issue
    Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

    Recommended action: Upgrade to 5.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    Apache Kylin Authentication Bypass Vulnerability

    CVE-2025-61733 · GHSA-mr9j-4j48-xcm2

    Affected
    • Maven org.apache.kylin:kylin-core-common >= 4.0.0, < 5.0.3
    Fixed in
    5.0.3· Vendor fix available
    Issue
    Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

    Recommended action: Upgrade to 5.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.3MavenPublished

    Apache Kylin Server-Side Request Forgery (SSRF) Vulnerability

    CVE-2025-61735 · GHSA-f6m8-qm7j-fh65

    Affected
    • Maven org.apache.kylin:kylin-core-common >= 4.0.0, < 5.0.3
    Fixed in
    5.0.3· Vendor fix available
    Issue
    Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

    Recommended action: Upgrade to 5.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Apache Kylin has Insufficiently Protected Credentials

    CVE-2023-29055 · GHSA-3vvc-v8c2-43r7

    Affected
    • Maven org.apache.kylin:kylin-core-common >= 2.0.0, < 4.0.4
    Fixed in
    4.0.4· Vendor fix available
    Issue
    In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file 'kylin.properties', that may contain serverside credentials. When the kylin service runs over HTTP (or other plain text protocol), it is possible for network sniffers to hijack the HTTP payload and get access to the content of kylin.properties and potentially the containing credentials. To avoid this threat, users are recommended to Always turn on HTTPS so that network payload is encrypted. Avoid putting credentials in kylin.properties, or at least not in plain text. Use network firewalls to protect the serverside such that it is not accessible to external attackers. Upgrade to version Apache Kylin 4.0.4, which filters out the sensitive content that goes to the Server Config web interface.

    Recommended action: Upgrade to 4.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.8MavenPublished

    Apache Kylin vulnerable to remote code execution

    CVE-2022-24697 · GHSA-ppxx-m926-g569

    Affected
    • Maven org.apache.kylin:kylin-core-common < 4.0.2
    Fixed in
    4.0.2· Vendor fix available
    Issue
    Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.

    Recommended action: Upgrade to 4.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 8.8Exploited · CISA KEVMavenPublished

    Command Injection in Kylin

    CVE-2020-1956 · GHSA-gprm-xqrc-c2j3

    Affected
    • Maven org.apache.kylin:kylin-core-common < 2.6.6; >= 3.0.0, < 3.0.2
    Fixed in
    3.0.22.6.6· Vendor fix available
    Issue
    Kylin has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

    Recommended action: Upgrade to 3.0.2 or 2.6.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →