Skip to content

← Actionable
High, CVSS 7.5

Apache Kylin has Insufficiently Protected Credentials

CVE-2023-29055GHSA-3vvc-v8c2-43r7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kylin:kylin-core-common 4.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-29055: 1.15% estimated exploitation activity in the next 30 days; percentile 66.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file 'kylin.properties', that may contain serverside credentials. When the kylin service runs over HTTP (or other plain text protocol), it is possible for network sniffers to hijack the HTTP payload and get access to the content of kylin.properties and potentially the containing credentials. To avoid this threat, users are recommended to Always turn on HTTPS so that network payload is encrypted. Avoid putting credentials in kylin.properties, or at least not in plain text. Use network firewalls to protect the serverside such that it is not accessible to external attackers. Upgrade to version Apache Kylin 4.0.4, which filters out the sensitive content that goes to the Server Config web interface.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3vvc-v8c2-43r7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-29055

Advisory: Apache Kylin has Insufficiently Protected Credentials
IDs: CVE-2023-29055, GHSA-3vvc-v8c2-43r7
Record: https://patchnext.com/advisories/cve-2023-29055 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.kylin:kylin-core-common 4.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.kylin:kylin-core-common: affected >= 2.0.0, < 4.0.4; fixed in 4.0.4

## Suggested inspection (read-only)
- Maven org.apache.kylin:kylin-core-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.kylin:kylin-core-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3vvc-v8c2-43r7 (GitHub-reviewed advisory GHSA-3vvc-v8c2-43r7 lists affected ranges: Maven org.apache.kylin:kylin-core-common >=2.0.0 <4.0.4)

Commands are suggestions: review each one before running it.

Loading voting…