Skip to content

← Actionable
High, CVSS 8.8Exploited · CISA KEV

Command Injection in Kylin

CVE-2020-1956GHSA-gprm-xqrc-c2j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kylin:kylin-core-common 3.0.2, 2.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2020-1956: 97.39% estimated exploitation activity in the next 30 days; percentile 99.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Kylin has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gprm-xqrc-c2j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-1956

Advisory: Command Injection in Kylin
IDs: CVE-2020-1956, GHSA-gprm-xqrc-c2j3
Record: https://patchnext.com/advisories/cve-2020-1956 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.kylin:kylin-core-common 3.0.2, 2.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.kylin:kylin-core-common: affected < 2.6.6; >= 3.0.0, < 3.0.2; fixed in 3.0.2, 2.6.6

## Suggested inspection (read-only)
- Maven org.apache.kylin:kylin-core-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.kylin:kylin-core-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gprm-xqrc-c2j3 (GitHub-reviewed advisory GHSA-gprm-xqrc-c2j3 lists affected ranges: Maven org.apache.kylin:kylin-core-common >=0 =3.0.0 <3.0.2)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2020-1956 to the Known Exploited Vulnerabilities catalog on 2022-03-25.)

Commands are suggestions: review each one before running it.

Loading voting…