Skip to content

← Public intelligence

Maven package

org.apache.camel:camel-support

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.2MavenPublished

    Apache Camel Message Header Injection through request parameters

    CVE-2025-29891 · GHSA-96v5-c2h5-56hm

    Affected
    • Maven org.apache.camel:camel-support >= 3.10.0, < 3.22.4; >= 4.9.0, < 4.10.2; >= 4.0.0-M1, < 4.8.5
    Fixed in
    4.8.53.22.44.10.2· Vendor fix available
    Issue
    Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.9.0 before 4.10.2, from 4.0.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component. If you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers. The headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation. All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow,…

    Recommended action: Upgrade to 4.10.2, 4.8.5 or 3.22.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.3MavenPublished

    Apache Camel: Camel Message Header Injection via Improper Filtering

    CVE-2025-27636 · GHSA-2c2h-2855-mf97

    Affected
    • Maven org.apache.camel:camel-support >= 3.10.0, < 3.22.4; >= 4.9.0, < 4.10.2; >= 4.0.0-M1, < 4.8.5
    Fixed in
    4.8.53.22.44.10.2· Vendor fix available
    Issue
    Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue affects Apache Camel: from 4.9.0 through <= 4.10.1, from 4.8.0 through <= 4.8.4, from 3.10.0 through <= 3.22.3. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, to call another method on the bean, than was coded in the application. In the camel-jms component, then a malicious header can be used to send the message to another queue (on the same broker) than was coded in the application. This could also be seen by using the camel-exec component. The attacker would need to inject custom headers, such as HTTP protocols. So if you have Camel applications that are directly connected to the internet via HTTP,…

    Recommended action: Upgrade to 4.10.2, 4.8.5 or 3.22.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →