Skip to content

← Actionable
Medium, CVSS 6.3

Apache Camel: Camel Message Header Injection via Improper Filtering

CVE-2025-27636GHSA-2c2h-2855-mf97

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-support 4.10.2, 4.8.5, 3.22.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-27636: 97.06% estimated exploitation activity in the next 30 days; percentile 99.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue affects Apache Camel: from 4.9.0 through <= 4.10.1, from 4.8.0 through <= 4.8.4, from 3.10.0 through <= 3.22.3. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, to call another method on the bean, than was coded in the application. In the camel-jms component, then a malicious header can be used to send the message to another queue (on the same broker) than was coded in the application. This could also be seen by using the camel-exec component. The attacker would need to inject custom headers, such as HTTP protocols. So if you have Camel applications that are directly connected to the internet via HTTP,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2c2h-2855-mf97

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27636

Advisory: Apache Camel: Camel Message Header Injection via Improper Filtering
IDs: CVE-2025-27636, GHSA-2c2h-2855-mf97
Record: https://patchnext.com/advisories/cve-2025-27636 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-support 4.10.2, 4.8.5, 3.22.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.camel:camel-support: affected >= 3.10.0, < 3.22.4; >= 4.9.0, < 4.10.2; >= 4.0.0-M1, < 4.8.5; fixed in 4.8.5, 3.22.4, 4.10.2

## Suggested inspection (read-only)
- Maven org.apache.camel:camel-support: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.camel:camel-support.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2c2h-2855-mf97 (GitHub-reviewed advisory GHSA-2c2h-2855-mf97 lists affected ranges: Maven org.apache.camel:camel-support >=3.10.0 =4.9.0 =4.0.0-M1 <4.8.5)

Commands are suggestions: review each one before running it.

Loading voting…