Apache Camel Message Header Injection through request parameters
CVE-2025-29891GHSA-96v5-c2h5-56hm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-support 4.10.2, 4.8.5, 3.22.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.camel:camel-support
- Affected
- >= 3.10.0, < 3.22.4>= 4.9.0, < 4.10.2>= 4.0.0-M1, < 4.8.5
- Fixed in
- 4.8.5, 3.22.4, 4.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-96v5-c2h5-56hm lists affected ranges: Maven org.apache.camel:camel-support >=3.10.0 =4.9.0 =4.0.0-M1 <4.8.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2025-29891: 76.09% estimated exploitation activity in the next 30 days; percentile 99.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.9.0 before 4.10.2, from 4.0.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component. If you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers. The headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation. All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-96v5-c2h5-56hm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-29891 Advisory: Apache Camel Message Header Injection through request parameters IDs: CVE-2025-29891, GHSA-96v5-c2h5-56hm Record: https://patchnext.com/advisories/cve-2025-29891 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-support 4.10.2, 4.8.5, 3.22.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.camel:camel-support: affected >= 3.10.0, < 3.22.4; >= 4.9.0, < 4.10.2; >= 4.0.0-M1, < 4.8.5; fixed in 4.8.5, 3.22.4, 4.10.2 ## Suggested inspection (read-only) - Maven org.apache.camel:camel-support: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.camel:camel-support. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-96v5-c2h5-56hm (GitHub-reviewed advisory GHSA-96v5-c2h5-56hm lists affected ranges: Maven org.apache.camel:camel-support >=3.10.0 =4.9.0 =4.0.0-M1 <4.8.5) Commands are suggestions: review each one before running it.
Loading voting…