Skip to content

← Public intelligence

Maven package

io.jenkins.plugins:cavisson-ns-nd-integration

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 3.1MavenPublished

    Jenkins NS-ND Integration Performance Publisher Plugin displays credentials without masking

    CVE-2023-33000 · GHSA-gqxr-hvrw-6hfh

    Affected
    • Maven io.jenkins.plugins:cavisson-ns-nd-integration < 4.11.0.48
    Fixed in
    4.11.0.48· Vendor fix available
    Issue
    Jenkins NS-ND Integration Performance Publisher Plugin stores credentials in job config.xml files on the Jenkins controller as part of its configuration. While these credentials are stored encrypted on disk, in NS-ND Integration Performance Publisher Plugin 4.8.0.149 and earlier, the job configuration form does not mask these credentials, increasing the potential for attackers to observe and capture them. NS-ND Integration Performance Publisher Plugin 4.11.0.48 masks credentials displayed on the configuration form.

    Recommended action: Upgrade to 4.11.0.48 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Plaintext Storage of a Password in Jenkins NS-ND Integration Performance Publisher Plugin

    CVE-2022-45392 · GHSA-x2w2-5552-fjv6

    Affected
    • Maven io.jenkins.plugins:cavisson-ns-nd-integration <= 4.8.0.143
    Fixed in
    4.8.0.146· Vendor fix available
    Issue
    NS-ND Integration Performance Publisher Plugin 4.8.0.143 and earlier stores passwords unencrypted in job config.xml files on the Jenkins controller as part of its configuration. These passwords can be viewed by attackers with Item/Extended Read permission or access to the Jenkins controller file system. NS-ND Integration Performance Publisher Plugin 4.8.0.146 stores passwords encrypted once job configurations are saved again.

    Recommended action: Upgrade to 4.8.0.146 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.9MavenPublished

    Jenkins NS-ND Integration Performance Publisher Plugin disables SSL/TLS certificate validation globally and unconditionally

    CVE-2022-45391 · GHSA-3vwm-fc87-mq6h

    Affected
    • Maven io.jenkins.plugins:cavisson-ns-nd-integration < 4.8.0.146
    Fixed in
    4.8.0.146· Vendor fix available
    Issue
    Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.143 and earlier globally and unconditionally disables SSL/TLS certificate and hostname validation for the entire Jenkins controller JVM. NS-ND Integration Performance Publisher Plugin 4.8.0.146 no longer disables SSL/TLS certificate and hostname validation globally.

    Recommended action: Upgrade to 4.8.0.146 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.3MavenPublished

    Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Missing Authorization

    CVE-2022-41228 · GHSA-j2mj-g8jp-gjfm

    Affected
    • Maven io.jenkins.plugins:cavisson-ns-nd-integration <= 4.8.0.129
    Fixed in
    4.8.0.130· Vendor fix available
    Issue
    A missing permission check in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers with Overall/Read permissions to connect to an attacker-specified webserver using attacker-specified credentials. Version 4.8.0.130 requires POST requests and Overall/Administer permission for the affected form validation method.

    Recommended action: Upgrade to 4.8.0.130 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.0MavenPublished

    Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-site Scripting

    CVE-2022-41229 · GHSA-fq2h-r2h9-pj8r

    Affected
    • Maven io.jenkins.plugins:cavisson-ns-nd-integration < 4.8.0.147
    Fixed in
    4.8.0.147· Vendor fix available
    Issue
    Jenkins NS-ND Integration Performance Publisher Plugin prior to version 4.8.0.147 does not escape configuration options of the Execute NetStorm/NetCloud Test build step, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

    Recommended action: Upgrade to 4.8.0.147 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 4.3MavenPublished

    Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-Site Request Forgery

    CVE-2022-41227 · GHSA-jjch-7g85-4m72

    Affected
    • Maven io.jenkins.plugins:cavisson-ns-nd-integration <= 4.8.0.129
    Fixed in
    4.8.0.130· Vendor fix available
    Issue
    A cross-site request forgery (CSRF) vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers to connect to an attacker-specified webserver using attacker-specified credentials. Version 4.8.0.130 requires POST requests and Overall/Administer permission for the affected form validation method.

    Recommended action: Upgrade to 4.8.0.130 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 8.0MavenPublished

    Cross-site Scripting in Jenkins NS-ND Integration Performance Publisher Plugin

    CVE-2022-34191 · GHSA-pv38-mqpp-v72h

    Affected
    • Maven io.jenkins.plugins:cavisson-ns-nd-integration < 4.8.0.129
    Fixed in
    4.8.0.129· Vendor fix available
    Issue
    Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.77 and earlier does not escape the name of NetStorm Test parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix. Additionally, several plugins have previously been updated to list parameters in a way that prevents exploitation by default, see SECURITY-2617 in the 2022-04-12 security advisory for a list.

    Recommended action: Upgrade to 4.8.0.129 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →