Jenkins NS-ND Integration Performance Publisher Plugin displays credentials without masking
CVE-2023-33000GHSA-gqxr-hvrw-6hfh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:cavisson-ns-nd-integration 4.11.0.48), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.plugins:cavisson-ns-nd-integration
- Affected
- < 4.11.0.48
- Fixed in
- 4.11.0.48
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gqxr-hvrw-6hfh lists affected ranges: Maven io.jenkins.plugins:cavisson-ns-nd-integration >=0 <4.11.0.48
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-33000: 0.57% estimated exploitation activity in the next 30 days; percentile 47.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins NS-ND Integration Performance Publisher Plugin stores credentials in job config.xml files on the Jenkins controller as part of its configuration. While these credentials are stored encrypted on disk, in NS-ND Integration Performance Publisher Plugin 4.8.0.149 and earlier, the job configuration form does not mask these credentials, increasing the potential for attackers to observe and capture them. NS-ND Integration Performance Publisher Plugin 4.11.0.48 masks credentials displayed on the configuration form.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gqxr-hvrw-6hfh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-33000 Advisory: Jenkins NS-ND Integration Performance Publisher Plugin displays credentials without masking IDs: CVE-2023-33000, GHSA-gqxr-hvrw-6hfh Record: https://patchnext.com/advisories/cve-2023-33000 (revision 1, source checked 26 Oct 2026, 16:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:cavisson-ns-nd-integration 4.11.0.48. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.plugins:cavisson-ns-nd-integration: affected < 4.11.0.48; fixed in 4.11.0.48 ## Suggested inspection (read-only) - Maven io.jenkins.plugins:cavisson-ns-nd-integration: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.plugins:cavisson-ns-nd-integration. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gqxr-hvrw-6hfh (GitHub-reviewed advisory GHSA-gqxr-hvrw-6hfh lists affected ranges: Maven io.jenkins.plugins:cavisson-ns-nd-integration >=0 <4.11.0.48) Commands are suggestions: review each one before running it.
Loading voting…