Skip to content

← Actionable
Medium, CVSS 5.9

Jenkins NS-ND Integration Performance Publisher Plugin disables SSL/TLS certificate validation globally and unconditionally

CVE-2022-45391GHSA-3vwm-fc87-mq6h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:cavisson-ns-nd-integration 4.8.0.146), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2022-45391: 0.44% estimated exploitation activity in the next 30 days; percentile 38.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.143 and earlier globally and unconditionally disables SSL/TLS certificate and hostname validation for the entire Jenkins controller JVM. NS-ND Integration Performance Publisher Plugin 4.8.0.146 no longer disables SSL/TLS certificate and hostname validation globally.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3vwm-fc87-mq6h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-45391

Advisory: Jenkins NS-ND Integration Performance Publisher Plugin disables SSL/TLS certificate validation globally and unconditionally
IDs: CVE-2022-45391, GHSA-3vwm-fc87-mq6h
Record: https://patchnext.com/advisories/cve-2022-45391 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:cavisson-ns-nd-integration 4.8.0.146. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.jenkins.plugins:cavisson-ns-nd-integration: affected < 4.8.0.146; fixed in 4.8.0.146

## Suggested inspection (read-only)
- Maven io.jenkins.plugins:cavisson-ns-nd-integration: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.jenkins.plugins:cavisson-ns-nd-integration.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3vwm-fc87-mq6h (GitHub-reviewed advisory GHSA-3vwm-fc87-mq6h lists affected ranges: Maven io.jenkins.plugins:cavisson-ns-nd-integration >=0 <4.8.0.146)

Commands are suggestions: review each one before running it.

Loading voting…