Skip to content

← Public intelligence

Maven package

io.dataease:dataease-plugin-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    DataEase API interface has IDOR vulnerability

    CVE-2023-32310 · GHSA-7hv6-gv38-78wj

    Affected
    • Maven io.dataease:dataease-plugin-common <= 1.18.6
    Fixed in
    1.18.7· Vendor fix available
    Issue
    Impact The api interface for DataEase delete dashboard and delete system messages is vulnerable to IDOR. The interface to delete the dashboard: 1. Create two users: user1 and user2 2. User1 creates a dashboard named pan1 3. User2 creates a dashboard named pan2 4. Both user1 and user2 share their dashboards with the demo user 5. User1 wants to delete his dashboard. We hijack the request with burpsuite. The request will probably look like this: POST /api/share/removePanelShares/440efa7f-efd8-11ed-bec7-1144724bc08c HTTP/1.1. 440efa7f-efd8-11ed-bec7-1144724bc08c is the ID of pan1 6. We replace this ID with the ID of pan2 and continue the execution (i.e. we delete the shares of others) 7. Successfully remove the shared link The interface to delete system messages: 1. Our request to delete a message is shown below 2. We can delete all messages by simply enumerating the message ID, regardless of whether the message belongs to the requester or not. 3. The interface for marking read messages…

    Recommended action: Upgrade to 1.18.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    MySQL JDBC deserialization vulnerability

    CVE-2022-39312 · GHSA-q4qq-jhjv-7rh2

    Affected
    • Maven io.dataease:dataease-plugin-common < 1.15.2
    Fixed in
    1.15.2· Vendor fix available
    Issue
    Impact In Dataease, the Mysql data source in the data source function can customize the JDBC connection parameters and the Mysql server target to be connected. In backend/src/main/java/io/dataease/provider/datasource/JdbcProvider.java, MysqlConfiguration class don't filter any parameters, directly concat user input. So, if the attack add some parameters in JDBC url, and connect to evil mysql server, he can trigger the mysql jdbc deserialization vulnerability, and eventually the attacker can execute through the deserialization vulnerability system commands and obtain server privileges. Affected versions: < 1.15.2 Patches The vulnerability has been fixed in v1.15.2. https://github.com/dataease/dataease/blob/6c3a011955c5c753ffd616d030bea5db4793c51c/backend/src/main/java/io/dataease/dto/datasource/MysqlConfiguration.java#L19 the MysqlConfiguration class use illegalParameters filter illegal parameters to fix this vulnerability. Workarounds It is recommended to upgrade the version to…

    Recommended action: Upgrade to 1.15.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8MavenPublished

    Dataease v1.11.1 SQL Injection via parameter dataSourceId

    CVE-2022-34115 · GHSA-vjmr-6pmm-rprf

    Affected
    • Maven io.dataease:dataease-plugin-common < 1.11.2
    Fixed in
    1.11.2· Vendor fix available
    Issue
    Dataease v1.11.1 was discovered to contain a SQL injection vulnerability via the parameter dataSourceId. Version 1.11.2 contains a fix.

    Recommended action: Upgrade to 1.11.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.5MavenPublished

    Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin

    CVE-2022-34112 · GHSA-c2pj-rr68-pw94

    Affected
    • Maven io.dataease:dataease-plugin-common <= 1.11.1
    Fixed in
    1.11.2· Vendor fix available
    Issue
    An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator. Version 1.11.2 contains a patch for this issue.

    Recommended action: Upgrade to 1.11.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.8MavenPublished

    SQL Injection found in Dataease

    CVE-2022-34114 · GHSA-hmvw-66jm-h9fh

    Affected
    • Maven io.dataease:dataease-plugin-common < 1.11.2
    Fixed in
    1.11.2· Vendor fix available
    Issue
    Dataease v1.11.1 was discovered to contain a SQL injection vulnerability via the parameter dataSourceId. Version 1.11.2 contains a fix.

    Recommended action: Upgrade to 1.11.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Critical, CVSS 9.8MavenPublished

    Dataease before 1.11.2 allows arbitrary code execution via crafter plugin

    CVE-2022-34113 · GHSA-5469-c5p2-xv5g

    Affected
    • Maven io.dataease:dataease-plugin-common <= 1.11.1
    Fixed in
    1.11.2· Vendor fix available
    Issue
    An issue in the component /api/plugin/upload of Dataease v1.11.1 allows attackers to execute arbitrary code via a crafted plugin. Version 1.11.2 contains a patch for the problem.

    Recommended action: Upgrade to 1.11.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →