Skip to content

← Actionable
Critical, CVSS 9.8

MySQL JDBC deserialization vulnerability

CVE-2022-39312GHSA-q4qq-jhjv-7rh2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.dataease:dataease-plugin-common 1.15.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-39312: 1.93% estimated exploitation activity in the next 30 days; percentile 79.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Dataease, the Mysql data source in the data source function can customize the JDBC connection parameters and the Mysql server target to be connected. In backend/src/main/java/io/dataease/provider/datasource/JdbcProvider.java, MysqlConfiguration class don't filter any parameters, directly concat user input. So, if the attack add some parameters in JDBC url, and connect to evil mysql server, he can trigger the mysql jdbc deserialization vulnerability, and eventually the attacker can execute through the deserialization vulnerability system commands and obtain server privileges. Affected versions: < 1.15.2 Patches The vulnerability has been fixed in v1.15.2. https://github.com/dataease/dataease/blob/6c3a011955c5c753ffd616d030bea5db4793c51c/backend/src/main/java/io/dataease/dto/datasource/MysqlConfiguration.java#L19 the MysqlConfiguration class use illegalParameters filter illegal parameters to fix this vulnerability. Workarounds It is recommended to upgrade the version to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q4qq-jhjv-7rh2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39312

Advisory: MySQL JDBC deserialization vulnerability
IDs: CVE-2022-39312, GHSA-q4qq-jhjv-7rh2
Record: https://patchnext.com/advisories/cve-2022-39312 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.dataease:dataease-plugin-common 1.15.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.dataease:dataease-plugin-common: affected < 1.15.2; fixed in 1.15.2

## Suggested inspection (read-only)
- Maven io.dataease:dataease-plugin-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.dataease:dataease-plugin-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q4qq-jhjv-7rh2 (GitHub-reviewed advisory GHSA-q4qq-jhjv-7rh2 lists affected ranges: Maven io.dataease:dataease-plugin-common >=0 <1.15.2)

Commands are suggestions: review each one before running it.

Loading voting…