DataEase API interface has IDOR vulnerability
CVE-2023-32310GHSA-7hv6-gv38-78wj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.dataease:dataease-plugin-common 1.18.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.dataease:dataease-plugin-common
- Affected
- <= 1.18.6
- Fixed in
- 1.18.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7hv6-gv38-78wj lists affected ranges: Maven io.dataease:dataease-plugin-common >=0 <=1.18.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2023-32310: 1.01% estimated exploitation activity in the next 30 days; percentile 63.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The api interface for DataEase delete dashboard and delete system messages is vulnerable to IDOR. The interface to delete the dashboard: 1. Create two users: user1 and user2 2. User1 creates a dashboard named pan1 3. User2 creates a dashboard named pan2 4. Both user1 and user2 share their dashboards with the demo user 5. User1 wants to delete his dashboard. We hijack the request with burpsuite. The request will probably look like this: POST /api/share/removePanelShares/440efa7f-efd8-11ed-bec7-1144724bc08c HTTP/1.1. 440efa7f-efd8-11ed-bec7-1144724bc08c is the ID of pan1 6. We replace this ID with the ID of pan2 and continue the execution (i.e. we delete the shares of others) 7. Successfully remove the shared link The interface to delete system messages: 1. Our request to delete a message is shown below 2. We can delete all messages by simply enumerating the message ID, regardless of whether the message belongs to the requester or not. 3. The interface for marking read messages…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7hv6-gv38-78wj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-32310 Advisory: DataEase API interface has IDOR vulnerability IDs: CVE-2023-32310, GHSA-7hv6-gv38-78wj Record: https://patchnext.com/advisories/cve-2023-32310 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.dataease:dataease-plugin-common 1.18.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.dataease:dataease-plugin-common: affected <= 1.18.6; fixed in 1.18.7 ## Suggested inspection (read-only) - Maven io.dataease:dataease-plugin-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.dataease:dataease-plugin-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7hv6-gv38-78wj (GitHub-reviewed advisory GHSA-7hv6-gv38-78wj lists affected ranges: Maven io.dataease:dataease-plugin-common >=0 <=1.18.6) Commands are suggestions: review each one before running it.
Loading voting…