Skip to content

← Public intelligence

Maven package

com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Cross-site request forgery in Jenkins Gerrit Trigger Plugin

    CVE-2023-24423 · GHSA-95jq-24cr-pgrq

    Affected
    • Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger < 2.38.1
    Fixed in
    2.38.1· Vendor fix available
    Issue
    A cross-site request forgery (CSRF) vulnerability in Jenkins Gerrit Trigger Plugin 2.38.0 and earlier allows attackers to rebuild previous builds triggered by Gerrit.

    Recommended action: Upgrade to 2.38.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    Missing permission check in Jenkins Gerrit Trigger Plugin

    CVE-2019-16552 · GHSA-4r39-f4rh-j6q8

    Affected
    • Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger < 2.30.2
    Fixed in
    2.30.2· Vendor fix available
    Issue
    A missing permission check in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials, or determine the existence of a file with a given path on the Jenkins master.

    Recommended action: Upgrade to 2.30.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8MavenPublished

    Cross-Site Request Forgery in Jenkins Gerrit Trigger Plugin

    CVE-2019-16551 · GHSA-vmvp-2hhx-rgm8

    Affected
    • Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger < 2.30.2
    Fixed in
    2.30.2· Vendor fix available
    Issue
    A cross-site request forgery vulnerability in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials.

    Recommended action: Upgrade to 2.30.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.4MavenPublished

    Incorrect Authorization in Jenkins Gerrit Trigger Plugin

    CVE-2018-1000106 · GHSA-4vf2-cm23-rf4c

    Affected
    • Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger < 2.27.5
    Fixed in
    2.27.5· Vendor fix available
    Issue
    An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to modify the Gerrit configuration in Jenkins.

    Recommended action: Upgrade to 2.27.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 4.3MavenPublished

    Incorrect Authorization in Jenkins Gerrit Trigger Plugin

    CVE-2018-1000105 · GHSA-wrqc-q8p5-76m5

    Affected
    • Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger < 2.27.5
    Fixed in
    2.27.5· Vendor fix available
    Issue
    An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to retrieve some configuration information about Gerrit in Jenkins.

    Recommended action: Upgrade to 2.27.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 8.0MavenPublished

    Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin

    CVE-2022-29039 · GHSA-455j-8hg5-8576

    Affected
    • Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger < 2.35.3
    Fixed in
    2.35.3· Vendor fix available
    Issue
    Jenkins Gerrit Trigger Plugin 2.35.2 and earlier does not escape the name and description of parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of these vulnerabilities requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.

    Recommended action: Upgrade to 2.35.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →