Skip to content

← Actionable
High, CVSS 8.0

Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin

CVE-2022-29039GHSA-455j-8hg5-8576

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger 2.35.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-29039: 0.83% estimated exploitation activity in the next 30 days; percentile 57.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Gerrit Trigger Plugin 2.35.2 and earlier does not escape the name and description of parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of these vulnerabilities requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-455j-8hg5-8576

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-29039

Advisory: Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin
IDs: CVE-2022-29039, GHSA-455j-8hg5-8576
Record: https://patchnext.com/advisories/cve-2022-29039 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger 2.35.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger: affected < 2.35.3; fixed in 2.35.3

## Suggested inspection (read-only)
- Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-455j-8hg5-8576 (GitHub-reviewed advisory GHSA-455j-8hg5-8576 lists affected ranges: Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger >=0 <2.35.3)

Commands are suggestions: review each one before running it.

Loading voting…