Cross-site request forgery in Jenkins Gerrit Trigger Plugin
CVE-2023-24423GHSA-95jq-24cr-pgrq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger 2.38.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
- Affected
- < 2.38.1
- Fixed in
- 2.38.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-95jq-24cr-pgrq lists affected ranges: Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger >=0 <2.38.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-24423: 0.49% estimated exploitation activity in the next 30 days; percentile 41.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A cross-site request forgery (CSRF) vulnerability in Jenkins Gerrit Trigger Plugin 2.38.0 and earlier allows attackers to rebuild previous builds triggered by Gerrit.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-95jq-24cr-pgrq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-24423 Advisory: Cross-site request forgery in Jenkins Gerrit Trigger Plugin IDs: CVE-2023-24423, GHSA-95jq-24cr-pgrq Record: https://patchnext.com/advisories/cve-2023-24423 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger 2.38.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger: affected < 2.38.1; fixed in 2.38.1 ## Suggested inspection (read-only) - Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-95jq-24cr-pgrq (GitHub-reviewed advisory GHSA-95jq-24cr-pgrq lists affected ranges: Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger >=0 <2.38.1) Commands are suggestions: review each one before running it.
Loading voting…