Skip to content

← Public intelligence

Maven package

com.graphql-java:graphql-java

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7MavenPublished

    GraphQL Java does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of service

    CVE-2024-40094 · GHSA-h9mq-f6q5-6c8m

    Affected
    • Maven com.graphql-java:graphql-java < 19.11; >= 20.0, < 20.9; >= 21.0, < 21.5
    Fixed in
    20.919.1121.5· Vendor fix available
    Issue
    GraphQL Java (aka graphql-java) before 21.5 does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of service via introspection queries. 20.9 and 19.11 are also fixed versions.

    Recommended action: Upgrade to 21.5, 20.9 or 19.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    GraphQL Java vulnerable to stack consumption

    CVE-2023-28867 · GHSA-p4qx-6w5p-4rj2

    Affected
    • Maven com.graphql-java:graphql-java < 0.0.0-2023-03-20T01-49-44-80e3135; >= 1.2, < 17.5; >= 18.0, < 18.4; >= 19.0, < 19.4; >= 20.0, <= 20.0
    Fixed in
    17.519.418.40.0.0-2023-03-20T01-49-44-80e313520.1· Vendor fix available
    Issue
    In GraphQL Java (aka graphql-java) before 20.1, an attacker can send a crafted GraphQL query that causes stack consumption. The fixed versions are 20.1, 19.4, 18.4, 17.5, and 0.0.0-2023-03-20T01-49-44-80e3135.

    Recommended action: Upgrade to 20.1, 19.4, 18.4 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    graphql-java vulnerable to Denial of Service via GraphQL query that consumes CPU resources

    CVE-2022-37734 · GHSA-v62j-cxhh-fq22

    Affected
    • Maven com.graphql-java:graphql-java < 17.4; >= 18.0, < 18.3
    Fixed in
    18.317.4· Vendor fix available
    Issue
    graphql-java before 19.0, 18.3, and 17.4 is vulnerable to Denial of Service. An attacker send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0, 18.3, and 17.4.

    Recommended action: Upgrade to 18.3 or 17.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →