Skip to content

← Actionable
High, CVSS 7.5

GraphQL Java vulnerable to stack consumption

CVE-2023-28867GHSA-p4qx-6w5p-4rj2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.graphql-java:graphql-java 20.1, 19.4, 18.4, 17.5, 0.0.0-2023-03-20T01-49-44-80e3135), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven com.graphql-java:graphql-java

    Affected
    < 0.0.0-2023-03-20T01-49-44-80e3135>= 1.2, < 17.5>= 18.0, < 18.4>= 19.0, < 19.4>= 20.0, <= 20.0
    Fixed in
    17.5, 19.4, 18.4, 0.0.0-2023-03-20T01-49-44-80e3135, 20.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-28867: 1.05% estimated exploitation activity in the next 30 days; percentile 64.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In GraphQL Java (aka graphql-java) before 20.1, an attacker can send a crafted GraphQL query that causes stack consumption. The fixed versions are 20.1, 19.4, 18.4, 17.5, and 0.0.0-2023-03-20T01-49-44-80e3135.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p4qx-6w5p-4rj2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-28867

Advisory: GraphQL Java vulnerable to stack consumption
IDs: CVE-2023-28867, GHSA-p4qx-6w5p-4rj2
Record: https://patchnext.com/advisories/cve-2023-28867 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.graphql-java:graphql-java 20.1, 19.4, 18.4, 17.5, 0.0.0-2023-03-20T01-49-44-80e3135. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.graphql-java:graphql-java: affected < 0.0.0-2023-03-20T01-49-44-80e3135; >= 1.2, < 17.5; >= 18.0, < 18.4; >= 19.0, < 19.4; >= 20.0, <= 20.0; fixed in 17.5, 19.4, 18.4, 0.0.0-2023-03-20T01-49-44-80e3135, 20.1

## Suggested inspection (read-only)
- Maven com.graphql-java:graphql-java: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.graphql-java:graphql-java.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p4qx-6w5p-4rj2 (GitHub-reviewed advisory GHSA-p4qx-6w5p-4rj2 lists affected ranges: Maven com.graphql-java:graphql-java >=0 =1.2 =18.0 =19.0 =20.0 <=20.0)

Commands are suggestions: review each one before running it.

Loading voting…