Skip to content

← Public intelligence

Go package

github.com/loft-sh/devspace

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.7GoPublished

    DevSpace UI Server WebSocket CheckOrigin does not validate source

    CVE-2026-42283 · GHSA-hqwm-7x7x-8379

    Affected
    • Go github.com/loft-sh/devspace >= 6.3.20, <= 6.3.20
    Fixed in
    6.3.21· Vendor fix available
    Issue
    DevSpace's UI server WebSocket accepts connections from all origins by default, and therefore several endpoints are exposed via this WebSocket. When a developer runs the DevSpace UI and at the same time uses a browser to access the internet, a malicious website they visit can use their browser to establish a cross-origin WebSocket connection to ws://127.0.0.1:8090. This allows an attacker to access: /api/logs to stream real-time pod logs /api/enter to open an interactive shell inside the running pod /api/command to execute pre-defined pipeline commands Patches Versions 6.3.21 and above are patched. Resources gorilla/websocket CheckOrigin documentation Installation Options Devspace is no longer publishing to NPM or Yarn, please continue to use our other installation methods to get updates in the future, including this patch. Credit DevSpace thanks @b0b0haha for finding and reporting this vulnerability.

    Recommended action: Upgrade to 6.3.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8GoPublished

    DevSpace vulnerable to remote code execution

    CVE-2020-15391 · GHSA-6h8c-gw33-cjm2

    Affected
    • Go github.com/loft-sh/devspace <= 4.13.0
    Fixed in
    4.14.0· Vendor fix available
    Issue
    The UI in DevSpace 4.13.0 allows web sites to execute actions on pods (on behalf of a victim) because of a lack of authentication for the WebSocket protocol. This leads to remote code execution.

    Recommended action: Upgrade to 4.14.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →