Skip to content

← Actionable
High, CVSS 7.7

DevSpace UI Server WebSocket CheckOrigin does not validate source

CVE-2026-42283GHSA-hqwm-7x7x-8379

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/loft-sh/devspace 6.3.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-42283: 0.15% estimated exploitation activity in the next 30 days; percentile 4.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description DevSpace's UI server WebSocket accepts connections from all origins by default, and therefore several endpoints are exposed via this WebSocket. When a developer runs the DevSpace UI and at the same time uses a browser to access the internet, a malicious website they visit can use their browser to establish a cross-origin WebSocket connection to ws://127.0.0.1:8090. This allows an attacker to access: /api/logs to stream real-time pod logs /api/enter to open an interactive shell inside the running pod /api/command to execute pre-defined pipeline commands Patches Versions 6.3.21 and above are patched. Resources gorilla/websocket CheckOrigin documentation Installation Options Devspace is no longer publishing to NPM or Yarn, please continue to use our other installation methods to get updates in the future, including this patch. Credit DevSpace thanks @b0b0haha for finding and reporting this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hqwm-7x7x-8379

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42283

Advisory: DevSpace UI Server WebSocket CheckOrigin does not validate source
IDs: CVE-2026-42283, GHSA-hqwm-7x7x-8379
Record: https://patchnext.com/advisories/cve-2026-42283 (revision 1, source checked 26 Oct 2026, 15:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/loft-sh/devspace 6.3.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/loft-sh/devspace: affected >= 6.3.20, <= 6.3.20; fixed in 6.3.21

## Suggested inspection (read-only)
- Go github.com/loft-sh/devspace: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/loft-sh/devspace.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hqwm-7x7x-8379 (GitHub-reviewed advisory GHSA-hqwm-7x7x-8379 lists affected ranges: Go github.com/loft-sh/devspace >=6.3.20 <=6.3.20)

Commands are suggestions: review each one before running it.

Loading voting…