DevSpace vulnerable to remote code execution
CVE-2020-15391GHSA-6h8c-gw33-cjm2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/loft-sh/devspace 4.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/loft-sh/devspace
- Affected
- <= 4.13.0
- Fixed in
- 4.14.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6h8c-gw33-cjm2 lists affected ranges: Go github.com/loft-sh/devspace >=0 <=4.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-15391: 2.72% estimated exploitation activity in the next 30 days; percentile 86.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The UI in DevSpace 4.13.0 allows web sites to execute actions on pods (on behalf of a victim) because of a lack of authentication for the WebSocket protocol. This leads to remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6h8c-gw33-cjm2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15391 Advisory: DevSpace vulnerable to remote code execution IDs: CVE-2020-15391, GHSA-6h8c-gw33-cjm2 Record: https://patchnext.com/advisories/cve-2020-15391 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/loft-sh/devspace 4.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/loft-sh/devspace: affected <= 4.13.0; fixed in 4.14.0 ## Suggested inspection (read-only) - Go github.com/loft-sh/devspace: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/loft-sh/devspace. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6h8c-gw33-cjm2 (GitHub-reviewed advisory GHSA-6h8c-gw33-cjm2 lists affected ranges: Go github.com/loft-sh/devspace >=0 <=4.13.0) Commands are suggestions: review each one before running it.
Loading voting…