Skip to content

← Public intelligence

npm package

mqtt-packet

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Improper Input Validation and Buffer Over-read in mqtt-packet

    CVE-2019-5432 · GHSA-wv67-9jq7-8r69

    Affected
    • npm mqtt-packet < 3.5.1; >= 4.0.0, < 4.1.3; >= 5.0.0, < 5.6.1; >= 6.0.0, < 6.1.2
    Fixed in
    4.1.35.6.16.1.23.5.1· Vendor fix available
    Issue
    A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.

    Recommended action: Upgrade to 6.1.2, 5.6.1, 4.1.3 or 3.5.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Denial of Service in mqtt-packet

    CVE-2016-10523 · GHSA-g3r2-65gc-qpqc

    Affected
    • npm mqtt-packet < 3.4.6; >= 4.0.0, < 4.0.5
    Fixed in
    3.4.64.0.5· Vendor fix available
    Issue
    Versions of mqtt-packet prior to 3.4.6, or 4.x prior to 4.0.5 are affected by a denial of service vulnerability wherein specific sequences of MQTT packets can crash the application. Recommendation Version 3.x: Update to version 3.4.6 or later. Version 4.x: Update to version 4.0.5 or later.

    Recommended action: Upgrade to 4.0.5 or 3.4.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →