Skip to content

← Actionable
Unratedamended

Denial of Service in mqtt-packet

CVE-2016-10523GHSA-g3r2-65gc-qpqc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mqtt-packet 4.0.5, 3.4.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mqtt-packet

    Affected
    < 3.4.6>= 4.0.0, < 4.0.5
    Fixed in
    3.4.6, 4.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2016-10523: 2.42% estimated exploitation activity in the next 30 days; percentile 84.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of mqtt-packet prior to 3.4.6, or 4.x prior to 4.0.5 are affected by a denial of service vulnerability wherein specific sequences of MQTT packets can crash the application. Recommendation Version 3.x: Update to version 3.4.6 or later. Version 4.x: Update to version 4.0.5 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g3r2-65gc-qpqc

  2. Revision 1 · created ·

    Published from osv record GHSA-g3r2-65gc-qpqc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10523

Advisory: Denial of Service in mqtt-packet
IDs: CVE-2016-10523, GHSA-g3r2-65gc-qpqc
Record: https://patchnext.com/advisories/cve-2016-10523 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mqtt-packet 4.0.5, 3.4.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mqtt-packet: affected < 3.4.6; >= 4.0.0, < 4.0.5; fixed in 3.4.6, 4.0.5

## Suggested inspection (read-only)
- `npm ls mqtt-packet --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mqtt-packet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g3r2-65gc-qpqc (OSV record GHSA-g3r2-65gc-qpqc lists affected ranges: npm mqtt-packet >=0 =4.0.0 <4.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-g3r2-65gc-qpqc (GitHub-reviewed advisory GHSA-g3r2-65gc-qpqc lists affected ranges: npm mqtt-packet >=0 =4.0.0 <4.0.5)

Commands are suggestions: review each one before running it.

Loading voting…