Skip to content

← Actionable
High, CVSS 7.5amended

Improper Input Validation and Buffer Over-read in mqtt-packet

CVE-2019-5432GHSA-wv67-9jq7-8r69

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mqtt-packet 6.1.2, 5.6.1, 4.1.3, 3.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mqtt-packet

    Affected
    < 3.5.1>= 4.0.0, < 4.1.3>= 5.0.0, < 5.6.1>= 6.0.0, < 6.1.2
    Fixed in
    4.1.3, 5.6.1, 6.1.2, 3.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-5432: 1.78% estimated exploitation activity in the next 30 days; percentile 78.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wv67-9jq7-8r69

  2. Revision 1 · created ·

    Published from osv record GHSA-wv67-9jq7-8r69

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-5432

Advisory: Improper Input Validation and Buffer Over-read in mqtt-packet
IDs: CVE-2019-5432, GHSA-wv67-9jq7-8r69
Record: https://patchnext.com/advisories/cve-2019-5432 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mqtt-packet 6.1.2, 5.6.1, 4.1.3, 3.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mqtt-packet: affected < 3.5.1; >= 4.0.0, < 4.1.3; >= 5.0.0, < 5.6.1; >= 6.0.0, < 6.1.2; fixed in 4.1.3, 5.6.1, 6.1.2, 3.5.1

## Suggested inspection (read-only)
- `npm ls mqtt-packet --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mqtt-packet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wv67-9jq7-8r69 (OSV record GHSA-wv67-9jq7-8r69 lists affected ranges: npm mqtt-packet >=0 =4.0.0 =5.0.0 =6.0.0 <6.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-wv67-9jq7-8r69 (GitHub-reviewed advisory GHSA-wv67-9jq7-8r69 lists affected ranges: npm mqtt-packet >=0 =4.0.0 =5.0.0 =6.0.0 <6.1.2)

Commands are suggestions: review each one before running it.

Loading voting…