Skip to content

← Public intelligence

npm package

mongo-express

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1npmAmendedPublished

    Cross-site scripting

    CVE-2021-21422 · GHSA-7p8h-86p5-wv3p

    Affected
    • npm mongo-express <= 1.0.0-alpha.2
    Fixed in
    1.0.0-alpha.4· Vendor fix available
    Issue
    Two kinds of XSS were found: 1. As mentioned in https://github.com/mongo-express/mongo-express/issues/577 when the content of a cell grows larger than supported size, clicking on a row will show full document unescaped, however this needs admin interaction on cell. 2. Data cells identified as media will be rendered as media, without being sanitized. Example of different renders: image, audio, video, etc. Impact As an example of type 1 attack, an unauthorized user who only can send a large amount of data in a field of a document may use this payload: This will send an export of a collection to the attacker without even admin knowing. Other types of attacks such as dropping a database\collection are also possible. Patches Upgrade to v1.0.0-alpha.4 For more information If you have any questions or comments about this advisory: Open an issue in mongo-express Email me at jafar.akhoondali@gmail.com

    Recommended action: Upgrade to 1.0.0-alpha.4 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.9Exploited · CISA KEVnpmAmendedPublished

    Remote Code Execution Vulnerability in NPM mongo-express

    CVE-2019-10758 · GHSA-h47j-hc6x-h3qq

    Affected
    • npm mongo-express < 0.54.0
    Fixed in
    0.54.0· Vendor fix available
    Issue
    Impact Remote code execution on the host machine by any authenticated user. Proof Of Concept Launching mongo-express on a Mac, pasting the following into the "create index" field will pop open the Mac calculator: Patches Users should upgrade to version 0.54.0 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? For more information If you have any questions or comments about this advisory: Open an issue in example link to repo Email us at example email address Thanks @JLLeitschuh for finding and reporting this vulnerability This vulnerability has been exploited in the wild.

    Recommended action: Upgrade to 0.54.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)cisa.gov (2)github.com (3)cisa.gov (4)Source checked Evidence →