Remote Code Execution Vulnerability in NPM mongo-express
CVE-2019-10758GHSA-h47j-hc6x-h3qq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongo-express 0.54.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mongo-express
- Affected
- < 0.54.0
- Fixed in
- 0.54.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h47j-hc6x-h3qq lists affected ranges: npm mongo-express >=0 <0.54.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2019-10758 to the Known Exploited Vulnerabilities catalog on 2021-12-10.
VerifiedObserved Listed in the CISA KEV JSON feed; separate from customer applicability.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h47j-hc6x-h3qq lists affected ranges: npm mongo-express >=0 <0.54.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2019-10758 to the Known Exploited Vulnerabilities catalog on 2021-12-10.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2021-12-10).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H
- EPSS
- CVE-2019-10758: 84.73% estimated exploitation activity in the next 30 days; percentile 99.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Remote code execution on the host machine by any authenticated user. Proof Of Concept Launching mongo-express on a Mac, pasting the following into the "create index" field will pop open the Mac calculator: Patches Users should upgrade to version 0.54.0 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? For more information If you have any questions or comments about this advisory: Open an issue in example link to repo Email us at example email address Thanks @JLLeitschuh for finding and reporting this vulnerability This vulnerability has been exploited in the wild.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h47j-hc6x-h3qq
- Revision 2 · evidence added ·
CISA KEV confirmed exploitation for CVE-2019-10758 (date added 2021-12-10). Customer workflow unchanged.
- Revision 1 · created ·
Published from osv record GHSA-h47j-hc6x-h3qq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10758 Advisory: Remote Code Execution Vulnerability in NPM mongo-express IDs: CVE-2019-10758, GHSA-h47j-hc6x-h3qq Record: https://patchnext.com/advisories/cve-2019-10758 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: mongo-express 0.54.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mongo-express: affected < 0.54.0; fixed in 0.54.0 ## Suggested inspection (read-only) - `npm ls mongo-express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mongo-express. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h47j-hc6x-h3qq (OSV record GHSA-h47j-hc6x-h3qq lists affected ranges: npm mongo-express >=0 <0.54.0 (fixed)) - Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2019-10758 to the Known Exploited Vulnerabilities catalog on 2021-12-10.) - Verified: https://github.com/advisories/GHSA-h47j-hc6x-h3qq (GitHub-reviewed advisory GHSA-h47j-hc6x-h3qq lists affected ranges: npm mongo-express >=0 <0.54.0) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-10758 to the Known Exploited Vulnerabilities catalog on 2021-12-10.) Commands are suggestions: review each one before running it.
Loading voting…