Skip to content

← Actionable
High, CVSS 8.1amended

Cross-site scripting

CVE-2021-21422GHSA-7p8h-86p5-wv3p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongo-express 1.0.0-alpha.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2021-21422: 1.57% estimated exploitation activity in the next 30 days; percentile 75.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Two kinds of XSS were found: 1. As mentioned in https://github.com/mongo-express/mongo-express/issues/577 when the content of a cell grows larger than supported size, clicking on a row will show full document unescaped, however this needs admin interaction on cell. 2. Data cells identified as media will be rendered as media, without being sanitized. Example of different renders: image, audio, video, etc. Impact As an example of type 1 attack, an unauthorized user who only can send a large amount of data in a field of a document may use this payload: This will send an export of a collection to the attacker without even admin knowing. Other types of attacks such as dropping a database\collection are also possible. Patches Upgrade to v1.0.0-alpha.4 For more information If you have any questions or comments about this advisory: Open an issue in mongo-express Email me at jafar.akhoondali@gmail.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7p8h-86p5-wv3p

  2. Revision 1 · created ·

    Published from osv record GHSA-7p8h-86p5-wv3p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21422

Advisory: Cross-site scripting
IDs: CVE-2021-21422, GHSA-7p8h-86p5-wv3p
Record: https://patchnext.com/advisories/cve-2021-21422 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mongo-express 1.0.0-alpha.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mongo-express: affected <= 1.0.0-alpha.2; fixed in 1.0.0-alpha.4

## Suggested inspection (read-only)
- `npm ls mongo-express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mongo-express.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7p8h-86p5-wv3p (OSV record GHSA-7p8h-86p5-wv3p lists affected ranges: npm mongo-express >=0 <1.0.0-alpha.4 (fixed))
- Verified: https://github.com/advisories/GHSA-7p8h-86p5-wv3p (GitHub-reviewed advisory GHSA-7p8h-86p5-wv3p lists affected ranges: npm mongo-express >=0 <=1.0.0-alpha.2)

Commands are suggestions: review each one before running it.

Loading voting…