Skip to content

← Public intelligence

npm package

keystone

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Authentication Weakness in keystone

    CVE-2015-9240 · GHSA-39pj-gq8q-9pfj

    Affected
    • npm keystone < 0.3.16
    Fixed in
    0.3.16· Vendor fix available
    Issue
    Versions of keystone prior to 0.3.16 are affected by a partial authentication bypass vulnerability. In the default sign in functionality, if an attacker provides a full and correct password, yet only provides part of the associated email address, authentication will be granted. Recommendation Update to version 0.3.16 or later.

    Recommended action: Upgrade to 0.3.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.8npmAmendedPublished

    Cross-Site Request Forgery (CSRF) in keystone

    CVE-2017-16570 · GHSA-q43c-g2g7-6gxj

    Affected
    • npm keystone <= 4.0.0-beta.6
    Fixed in
    4.0.0-beta.7· Vendor fix available
    Issue
    Versions of keystone prior to 4.0.0 are vulnerable to Cross-Site Request Forgery (CSRF). The package fails to validate the presence of the X-CSRF-Token header, which may allow attackers to carry actions on behalf of other users on all endpoints. Recommendation Update to version 4.0.0 or later.

    Recommended action: Upgrade to 4.0.0-beta.7 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 4.8npmAmendedPublished

    Cross-Site Scripting in keystone

    CVE-2017-15881 · GHSA-7cv6-gvx3-m54m

    Affected
    • npm keystone <= 4.0.0-beta6
    Fixed in
    4.0.0-beta7· Vendor fix available
    Issue
    Versions of keystone prior to 4.0.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to properly encode rendered HTML on admin-created blog posts. This allows attackers to execute arbitrary JavaScript in the victim's browser. Exploiting this vulnerability requires having access to an admin account. Recommendation Update to version 4.0.0 or later.

    Recommended action: Upgrade to 4.0.0-beta7 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.8npmAmendedPublished

    Keystone is vulnerable to CSV injection

    CVE-2017-15879 · GHSA-6494-v9fq-fgq2

    Affected
    • npm keystone <= 4.0.0-beta5
    Fixed in
    4.0.0-beta7· Vendor fix available
    Issue
    CSV Injection (aka Excel Macro Injection or Formula Injection) exists in admin/server/api/download.js and lib/list/getCSVData.js in KeystoneJS before 4.0.0-beta.7 via a value that is mishandled in a CSV export.

    Recommended action: Upgrade to 4.0.0-beta7 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 6.1npmAmendedPublished

    Cross-Site Scripting in keystone

    CVE-2017-15878 · GHSA-7qcx-jmrc-h2rr

    Affected
    • npm keystone < 4.0.0
    Fixed in
    4.0.0· Vendor fix available
    Issue
    Versions of keystone prior to 4.0.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize user input on the Contact Us page, allowing attackers to submit contact forms with malicious JavaScript in the message field. The output is not properly encoded leading an admin that opens new inquiry to execute the arbitrary JavaScript supplied in their browser. Recommendation Update to version 4.0.0 or later.

    Recommended action: Upgrade to 4.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →