Cross-Site Scripting in keystone
CVE-2017-15881GHSA-7cv6-gvx3-m54m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 4.0.0-beta7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm keystone
- Affected
- <= 4.0.0-beta6
- Fixed in
- 4.0.0-beta7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7cv6-gvx3-m54m lists affected ranges: npm keystone >=0 <4.0.0-beta7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7cv6-gvx3-m54m lists affected ranges: npm keystone >=0 <=4.0.0-beta6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-15881: 1.21% estimated exploitation activity in the next 30 days; percentile 68.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of keystone prior to 4.0.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to properly encode rendered HTML on admin-created blog posts. This allows attackers to execute arbitrary JavaScript in the victim's browser. Exploiting this vulnerability requires having access to an admin account. Recommendation Update to version 4.0.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7cv6-gvx3-m54m
- Revision 1 · created ·
Published from osv record GHSA-7cv6-gvx3-m54m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-15881 Advisory: Cross-Site Scripting in keystone IDs: CVE-2017-15881, GHSA-7cv6-gvx3-m54m Record: https://patchnext.com/advisories/cve-2017-15881 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keystone 4.0.0-beta7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm keystone: affected <= 4.0.0-beta6; fixed in 4.0.0-beta7 ## Suggested inspection (read-only) - `npm ls keystone --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keystone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7cv6-gvx3-m54m (OSV record GHSA-7cv6-gvx3-m54m lists affected ranges: npm keystone >=0 <4.0.0-beta7 (fixed)) - Verified: https://github.com/advisories/GHSA-7cv6-gvx3-m54m (GitHub-reviewed advisory GHSA-7cv6-gvx3-m54m lists affected ranges: npm keystone >=0 <=4.0.0-beta6) Commands are suggestions: review each one before running it.
Loading voting…