Cross-Site Request Forgery (CSRF) in keystone
CVE-2017-16570GHSA-q43c-g2g7-6gxj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 4.0.0-beta.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm keystone
- Affected
- <= 4.0.0-beta.6
- Fixed in
- 4.0.0-beta.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q43c-g2g7-6gxj lists affected ranges: npm keystone >=0 <4.0.0-beta.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q43c-g2g7-6gxj lists affected ranges: npm keystone >=0 <=4.0.0-beta.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-16570: 2.21% estimated exploitation activity in the next 30 days; percentile 82.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of keystone prior to 4.0.0 are vulnerable to Cross-Site Request Forgery (CSRF). The package fails to validate the presence of the X-CSRF-Token header, which may allow attackers to carry actions on behalf of other users on all endpoints. Recommendation Update to version 4.0.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q43c-g2g7-6gxj
- Revision 1 · created ·
Published from osv record GHSA-q43c-g2g7-6gxj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16570 Advisory: Cross-Site Request Forgery (CSRF) in keystone IDs: CVE-2017-16570, GHSA-q43c-g2g7-6gxj Record: https://patchnext.com/advisories/cve-2017-16570 (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keystone 4.0.0-beta.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm keystone: affected <= 4.0.0-beta.6; fixed in 4.0.0-beta.7 ## Suggested inspection (read-only) - `npm ls keystone --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keystone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q43c-g2g7-6gxj (OSV record GHSA-q43c-g2g7-6gxj lists affected ranges: npm keystone >=0 <4.0.0-beta.7 (fixed)) - Verified: https://github.com/advisories/GHSA-q43c-g2g7-6gxj (GitHub-reviewed advisory GHSA-q43c-g2g7-6gxj lists affected ranges: npm keystone >=0 <=4.0.0-beta.6) Commands are suggestions: review each one before running it.
Loading voting…