Skip to content

← Public intelligence

npm package

keycloak-connect

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    keycloak-connect contains Open redirect vulnerability in the Node.js adapter

    CVE-2022-2237 · GHSA-59fq-727j-hm3f

    Affected
    • npm keycloak-connect < 21.0.1
    Fixed in
    21.0.1· Vendor fix available
    Issue
    There is an Open Redirect vulnerability in the Node.js adapter when forwarding requests to Keycloak using checkSSO with query param prompt=none.

    Recommended action: Upgrade to 21.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.5npmAmendedPublished

    Forced Logout in keycloak-connect

    CVE-2019-10157 · GHSA-68hw-vfh7-xvg8

    Affected
    • npm keycloak-connect < 4.8.3
    Fixed in
    4.8.3· Vendor fix available
    Issue
    Versions of keycloak-connect prior to 4.4.0 are vulnerable to Forced Logout. The package fails to validate JWT signatures on the /klogout route, allowing attackers to logout users and craft malicious JWTs with NBF values that prevent user access indefinitely. Recommendation Upgrade to version 4.4.0 or later.

    Recommended action: Upgrade to 4.8.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8npmAmendedPublished

    keycloak-connect and keycloak-js improperly handle invalid tokens

    CVE-2017-7474 · GHSA-mw35-24gh-f82w

    Affected
    • npm keycloak-connect >= 2.5.0, < 3.1.0
    Fixed in
    3.1.0· Vendor fix available
    Issue
    It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens correctly. An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.

    Recommended action: Upgrade to 3.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →