Skip to content

← Actionable
Critical, CVSS 9.8amended

keycloak-connect and keycloak-js improperly handle invalid tokens

CVE-2017-7474GHSA-mw35-24gh-f82w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (keycloak-js 3.1.0; keycloak-connect 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-7474: 2.54% estimated exploitation activity in the next 30 days; percentile 85.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens correctly. An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mw35-24gh-f82w

  2. Revision 1 · created ·

    Published from osv record GHSA-mw35-24gh-f82w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-7474

Advisory: keycloak-connect and keycloak-js improperly handle invalid tokens
IDs: CVE-2017-7474, GHSA-mw35-24gh-f82w
Record: https://patchnext.com/advisories/cve-2017-7474 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: keycloak-js 3.1.0; keycloak-connect 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm keycloak-js: affected >= 2.5.0, < 3.1.0; fixed in 3.1.0
- npm keycloak-connect: affected >= 2.5.0, < 3.1.0; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls keycloak-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls keycloak-connect --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on keycloak-js, keycloak-connect.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mw35-24gh-f82w (OSV record GHSA-mw35-24gh-f82w lists affected ranges: npm keycloak-connect >=2.5.0 =2.5.0 <3.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mw35-24gh-f82w (GitHub-reviewed advisory GHSA-mw35-24gh-f82w lists affected ranges: npm keycloak-connect >=2.5.0 =2.5.0 <3.1.0)

Commands are suggestions: review each one before running it.

Loading voting…