Critical, CVSS 9.8npmAmendedPublished
keycloak-connect and keycloak-js improperly handle invalid tokens
CVE-2017-7474 · GHSA-mw35-24gh-f82w
- Affected
- npm keycloak-js >= 2.5.0, < 3.1.0
- Fixed in
- 3.1.0· Vendor fix available
- Issue
- It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens correctly. An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.
Recommended action: Upgrade to 3.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.