Skip to content

← Actionable
Medium, CVSS 5.5amended

Forced Logout in keycloak-connect

CVE-2019-10157GHSA-68hw-vfh7-xvg8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (keycloak-connect 4.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-10157: 0.21% estimated exploitation activity in the next 30 days; percentile 10.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of keycloak-connect prior to 4.4.0 are vulnerable to Forced Logout. The package fails to validate JWT signatures on the /klogout route, allowing attackers to logout users and craft malicious JWTs with NBF values that prevent user access indefinitely. Recommendation Upgrade to version 4.4.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-68hw-vfh7-xvg8

  2. Revision 1 · created ·

    Published from osv record GHSA-68hw-vfh7-xvg8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10157

Advisory: Forced Logout in keycloak-connect
IDs: CVE-2019-10157, GHSA-68hw-vfh7-xvg8
Record: https://patchnext.com/advisories/cve-2019-10157 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: keycloak-connect 4.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm keycloak-connect: affected < 4.8.3; fixed in 4.8.3

## Suggested inspection (read-only)
- `npm ls keycloak-connect --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on keycloak-connect.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-68hw-vfh7-xvg8 (OSV record GHSA-68hw-vfh7-xvg8 lists affected ranges: npm keycloak-connect >=0 <4.8.3 (fixed))
- Verified: https://github.com/advisories/GHSA-68hw-vfh7-xvg8 (GitHub-reviewed advisory GHSA-68hw-vfh7-xvg8 lists affected ranges: npm keycloak-connect >=0 <4.8.3)

Commands are suggestions: review each one before running it.

Loading voting…