Skip to content

← Public intelligence

npm package

express

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.0npmAmendedPublished

    Express ressource injection

    CVE-2024-10491 · GHSA-cm5g-3pgc-8rg4

    Affected
    • npm express <= 3.21.4
    Fixed in
    4.0.0-rc1· Vendor fix available
    Issue
    A vulnerability has been identified in the Express response.links function, allowing for arbitrary resource injection in the Link header when unsanitized data is used. The issue arises from improper sanitization in Link header values, which can allow a combination of characters like ,, ;, and < to preload malicious resources. This vulnerability is especially relevant for dynamic parameters.

    Recommended action: Upgrade to 4.0.0-rc1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Low, CVSS 2.1npmAmendedPublished

    Express Open Redirect vulnerability

    CVE-2024-9266 · GHSA-jj78-5fmv-mv28

    Affected
    • npm express >= 3.4.5, < 4.0.0-rc1
    Fixed in
    4.0.0-rc1· Vendor fix available
    Issue
    URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Express. This vulnerability affects the use of the Express Response object. This issue impacts Express: from 3.4.5 before 4.0.0-rc1.

    Recommended action: Upgrade to 4.0.0-rc1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Low, CVSS 2.3npmAmendedPublished

    express vulnerable to XSS via response.redirect()

    CVE-2024-43796 · GHSA-qw6h-vgh9-j6wx

    Affected
    • npm express < 4.20.0; >= 5.0.0-alpha.1, < 5.0.0
    Fixed in
    5.0.04.20.0· Vendor fix available
    Issue
    Impact In express <4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code Patches this issue is patched in express 4.20.0 Workarounds users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist Details successful exploitation of this vector requires the following: 1. The attacker MUST control the input to response.redirect() 1. express MUST NOT redirect before the template appears 1. the browser MUST NOT complete redirection before: 1. the user MUST click on the link in the template

    Recommended action: Upgrade to 5.0.0 or 4.20.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.1npmAmendedPublished

    Express.js Open Redirect in malformed URLs

    CVE-2024-29041 · GHSA-rv95-896h-c2vc

    Affected
    • npm express < 4.19.2; >= 5.0.0-alpha.1, < 5.0.0-beta.3
    Fixed in
    5.0.0-beta.34.19.2· Vendor fix available
    Issue
    Impact Versions of Express.js prior to 4.19.2 and pre-release alpha and beta versions before 5.0.0-beta.3 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode using encodeurl on the contents before passing it to the location header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method impacted is res.location() but this is also called from within res.redirect(). Patches https://github.com/expressjs/express/commit/0867302ddbde0e9463d0564fea5861feb708c2dd https://github.com/expressjs/express/commit/0b746953c4bd8e377123527db11f9cd866e39f94 An initial fix went out with express@4.19.0, we then patched a feature regression in 4.19.1 and added improved handling for the bypass in 4.19.2. Workarounds The fix…

    Recommended action: Upgrade to 5.0.0-beta.3 (pre-release) or 4.19.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 6.1npmAmendedPublished

    No Charset in Content-Type Header in express

    CVE-2014-6393 · GHSA-gpvr-g6gh-9mc2

    Affected
    • npm express < 3.11.0; >= 4.0.0, < 4.5.0
    Fixed in
    4.5.03.11.0· Vendor fix available
    Issue
    Vulnerable versions of express do not specify a charset field in the content-type header while displaying 400 level response messages. The lack of enforcing user's browser to set correct charset, could be leveraged by an attacker to perform a cross-site scripting attack, using non-standard encodings, like UTF-7. Recommendation For express 3.x, update express to version 3.11 or later. For express 4.x, update express to version 4.5 or later.

    Recommended action: Upgrade to 4.5.0 or 3.11.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →