No Charset in Content-Type Header in express
CVE-2014-6393GHSA-gpvr-g6gh-9mc2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express 4.5.0, 3.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm express
- Affected
- < 3.11.0>= 4.0.0, < 4.5.0
- Fixed in
- 4.5.0, 3.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gpvr-g6gh-9mc2 lists affected ranges: npm express >=0 =4.0.0 <4.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gpvr-g6gh-9mc2 lists affected ranges: npm express >=0 =4.0.0 <4.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2014-6393: 1.14% estimated exploitation activity in the next 30 days; percentile 66.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerable versions of express do not specify a charset field in the content-type header while displaying 400 level response messages. The lack of enforcing user's browser to set correct charset, could be leveraged by an attacker to perform a cross-site scripting attack, using non-standard encodings, like UTF-7. Recommendation For express 3.x, update express to version 3.11 or later. For express 4.x, update express to version 4.5 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gpvr-g6gh-9mc2
- Revision 1 · created ·
Published from osv record GHSA-gpvr-g6gh-9mc2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-6393 Advisory: No Charset in Content-Type Header in express IDs: CVE-2014-6393, GHSA-gpvr-g6gh-9mc2 Record: https://patchnext.com/advisories/cve-2014-6393 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express 4.5.0, 3.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express: affected < 3.11.0; >= 4.0.0, < 4.5.0; fixed in 4.5.0, 3.11.0 ## Suggested inspection (read-only) - `npm ls express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gpvr-g6gh-9mc2 (OSV record GHSA-gpvr-g6gh-9mc2 lists affected ranges: npm express >=0 =4.0.0 <4.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-gpvr-g6gh-9mc2 (GitHub-reviewed advisory GHSA-gpvr-g6gh-9mc2 lists affected ranges: npm express >=0 =4.0.0 <4.5.0) Commands are suggestions: review each one before running it.
Loading voting…