express vulnerable to XSS via response.redirect()
CVE-2024-43796GHSA-qw6h-vgh9-j6wx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express 5.0.0, 4.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm express
- Affected
- < 4.20.0>= 5.0.0-alpha.1, < 5.0.0
- Fixed in
- 5.0.0, 4.20.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qw6h-vgh9-j6wx lists affected ranges: npm express >=0 =5.0.0-alpha.1 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qw6h-vgh9-j6wx lists affected ranges: npm express >=0 =5.0.0-alpha.1 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L · score source
- EPSS
- CVE-2024-43796: 0.49% estimated exploitation activity in the next 30 days; percentile 41.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In express <4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code Patches this issue is patched in express 4.20.0 Workarounds users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist Details successful exploitation of this vector requires the following: 1. The attacker MUST control the input to response.redirect() 1. express MUST NOT redirect before the template appears 1. the browser MUST NOT complete redirection before: 1. the user MUST click on the link in the template
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qw6h-vgh9-j6wx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qw6h-vgh9-j6wx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-43796 Advisory: express vulnerable to XSS via response.redirect() IDs: CVE-2024-43796, GHSA-qw6h-vgh9-j6wx Record: https://patchnext.com/advisories/cve-2024-43796 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express 5.0.0, 4.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express: affected < 4.20.0; >= 5.0.0-alpha.1, < 5.0.0; fixed in 5.0.0, 4.20.0 ## Suggested inspection (read-only) - `npm ls express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qw6h-vgh9-j6wx (OSV record GHSA-qw6h-vgh9-j6wx lists affected ranges: npm express >=0 =5.0.0-alpha.1 <5.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qw6h-vgh9-j6wx (GitHub-reviewed advisory GHSA-qw6h-vgh9-j6wx lists affected ranges: npm express >=0 =5.0.0-alpha.1 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…