Skip to content

← Public intelligence

npm package

ecstatic

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Denial of Service in ecstatic

    CVE-2019-10775 · GHSA-jc84-3g44-wf2q

    Affected
    • npm ecstatic < 4.1.3
    Fixed in
    4.1.3· Vendor fix available
    Issue
    ecstatic have a denial of service vulnerability. Successful exploitation could lead to crash of an application.

    Recommended action: Upgrade to 4.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Open Redirect in ecstatic

    GHSA-9q64-mpxx-87fg

    Affected
    • npm ecstatic < 2.2.2; >= 3.0.0, < 3.3.2; >= 4.0.0, < 4.1.2
    Fixed in
    4.1.22.2.23.3.2· Vendor fix available
    Issue
    Versions of ecstatic prior to 4.1.2, 3.3.2 or 2.2.2 are vulnerable to Open Redirect. The package fails to validate redirects, allowing attackers to craft requests that result in an HTTP 301 redirect to any other domains. Recommendation If using ecstatic 4.x, upgrade to 4.1.2 or later. If using ecstatic 3.x, upgrade to 3.3.2 or later. If using ecstatic 2.x, upgrade to 2.2.2 or later.

    Recommended action: Upgrade to 4.1.2, 3.3.2 or 2.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. UnratednpmAmendedPublished

    Denial of Service in ecstatic

    CVE-2015-9242 · GHSA-vwjc-q9px-r9vq

    Affected
    • npm ecstatic < 1.4.0
    Fixed in
    1.4.0· Vendor fix available
    Issue
    Versions of ecstatic prior to 1.4.0 are affected by a denial of service vulnerability when certain input strings are sent via the Last-Modified or If-Modified-Since headers. Parsing certain inputs with new Date() or Date.parse() cases v8 to crash. As ecstatic passes the value of the affected headers into one of these functions, sending certain inputs via one of the headers will cause the server to crash. Recommendation Update to version 1.4.0 or later.

    Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 7.5npmAmendedPublished

    Denial of Service in ecstatic

    CVE-2016-10703 · GHSA-pm9p-9926-w68m

    Affected
    • npm ecstatic < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    ecstatic, a simple static file server middleware, is vulnerable to denial of service. If a payload with a large number of null bytes (%00) is provided by an attacker it can crash ecstatic by running it out of memory. Results from the original advisory Recommendation Update to version 2.0.0 or later.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →