Skip to content

← Actionable
High, CVSS 7.5amended

Denial of Service in ecstatic

CVE-2016-10703GHSA-pm9p-9926-w68m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ecstatic 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ecstatic

    Affected
    < 2.0.0
    Fixed in
    2.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2016-10703: 2.56% estimated exploitation activity in the next 30 days; percentile 85.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ecstatic, a simple static file server middleware, is vulnerable to denial of service. If a payload with a large number of null bytes (%00) is provided by an attacker it can crash ecstatic by running it out of memory. Results from the original advisory Recommendation Update to version 2.0.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pm9p-9926-w68m

  2. Revision 1 · created ·

    Published from osv record GHSA-pm9p-9926-w68m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10703

Advisory: Denial of Service in ecstatic
IDs: CVE-2016-10703, GHSA-pm9p-9926-w68m
Record: https://patchnext.com/advisories/cve-2016-10703 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ecstatic 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ecstatic: affected < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `npm ls ecstatic --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ecstatic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pm9p-9926-w68m (OSV record GHSA-pm9p-9926-w68m lists affected ranges: npm ecstatic >=0 <2.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pm9p-9926-w68m (GitHub-reviewed advisory GHSA-pm9p-9926-w68m lists affected ranges: npm ecstatic >=0 <2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…