Skip to content

← Actionable
Unratedamended

Denial of Service in ecstatic

CVE-2015-9242GHSA-vwjc-q9px-r9vq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ecstatic 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ecstatic

    Affected
    < 1.4.0
    Fixed in
    1.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2015-9242: 2.06% estimated exploitation activity in the next 30 days; percentile 81.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of ecstatic prior to 1.4.0 are affected by a denial of service vulnerability when certain input strings are sent via the Last-Modified or If-Modified-Since headers. Parsing certain inputs with new Date() or Date.parse() cases v8 to crash. As ecstatic passes the value of the affected headers into one of these functions, sending certain inputs via one of the headers will cause the server to crash. Recommendation Update to version 1.4.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vwjc-q9px-r9vq

  2. Revision 1 · created ·

    Published from osv record GHSA-vwjc-q9px-r9vq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-9242

Advisory: Denial of Service in ecstatic
IDs: CVE-2015-9242, GHSA-vwjc-q9px-r9vq
Record: https://patchnext.com/advisories/cve-2015-9242 (revision 2, source checked 26 Oct 2026, 12:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ecstatic 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ecstatic: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `npm ls ecstatic --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ecstatic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vwjc-q9px-r9vq (OSV record GHSA-vwjc-q9px-r9vq lists affected ranges: npm ecstatic >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vwjc-q9px-r9vq (GitHub-reviewed advisory GHSA-vwjc-q9px-r9vq lists affected ranges: npm ecstatic >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…