Skip to content

← Public intelligence

npm package

angular

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.0npmAmendedPublished

    XSS via JQLite DOM manipulation functions in AngularJS

    GHSA-5cp4-xmrw-59wf

    Affected
    • npm angular < 1.8.0
    Fixed in
    1.8.0· Vendor fix available
    Issue
    XSS may be triggered in AngularJS applications that sanitize user-controlled HTML snippets before passing them to JQLite methods like JQLite.prepend, JQLite.after, JQLite.append, JQLite.replaceWith, JQLite.append, new JQLite and angular.element. Description JQLite (DOM manipulation library that's part of AngularJS) manipulates input HTML before inserting it to the DOM in jqLiteBuildFragment. One of the modifications performed expands an XHTML self-closing tag. If jqLiteBuildFragment is called (e.g. via new JQLite(aString)) with user-controlled HTML string that was sanitized (e.g. with DOMPurify), the transformation done by JQLite may modify some forms of an inert, sanitized payload into a payload containing JavaScript - and trigger an XSS when the payload is inserted into DOM. This is similar to a bug in jQuery htmlPrefilter function that was fixed in 3.5.0. Proof of concept Note that the style element is not closed and <img would be a text node inside the style if inserted…

    Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.4npmAmendedPublished

    Angular vulnerable to Cross-site Scripting

    CVE-2020-7676 · GHSA-mhp6-pxh8-r675

    Affected
    • npm angular < 1.8.0
    Fixed in
    1.8.0· Vendor fix available
    Issue
    angular.js prior to 1.8.0 allows cross site scripting. The regex-based input HTML replacement may turn sanitized code into unsanitized one. Wrapping <option elements in <select ones changes parsing behavior, leading to possibly unsanitizing code.

    Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.1npmAmendedPublished

    AngularJS Cross-site Scripting due to failure to sanitize xlink.href attributes

    CVE-2019-14863 · GHSA-r5fx-8r73-v86c

    Affected
    • npm angular < 1.5.0-beta.1
    Fixed in
    1.5.0-beta.1· Vendor fix available
    Issue
    Versions of angular prior to 1.5.0-beta.1 are vulnerable to Cross-Site Scripting. The package fails to sanitize xlink:href attributes, which may allow attackers to execute arbitrary JavaScript in a victim's browser if the value is user-controlled. Recommendation Upgrade to version 1.5.0-beta.1 or later.

    Recommended action: Upgrade to 1.5.0-beta.1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 7.5npmAmendedPublished

    angular Prototype Pollution vulnerability

    CVE-2019-10768 · GHSA-89mq-4x47-5v83

    Affected
    • npm angular < 1.7.9
    Fixed in
    1.7.9· Vendor fix available
    Issue
    Versions of angular prior to 1.7.9 are vulnerable to prototype pollution. The deprecated API function merge() does not restrict the modification of an Object's prototype in the , which may allow an attacker to add or modify an existing property that will exist on all objects. Recommendation Upgrade to version 1.7.9 or later. The function was already deprecated and upgrades are not expected to break functionality.

    Recommended action: Upgrade to 1.7.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. UnratednpmAmendedPublished

    Cross-Site Scripting via JSONP

    GHSA-28hp-fgcr-2r4h

    Affected
    • npm angular < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    JSONP allows untrusted resource URLs, which provides a vector for attack by malicious actors.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →