Skip to content

← Actionable
Medium, CVSS 6.1amended

AngularJS Cross-site Scripting due to failure to sanitize xlink.href attributes

CVE-2019-14863GHSA-r5fx-8r73-v86c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (angular 1.5.0-beta.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm angular

    Affected
    < 1.5.0-beta.1
    Fixed in
    1.5.0-beta.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-14863: 1.20% estimated exploitation activity in the next 30 days; percentile 68.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of angular prior to 1.5.0-beta.1 are vulnerable to Cross-Site Scripting. The package fails to sanitize xlink:href attributes, which may allow attackers to execute arbitrary JavaScript in a victim's browser if the value is user-controlled. Recommendation Upgrade to version 1.5.0-beta.1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r5fx-8r73-v86c

  2. Revision 1 · created ·

    Published from osv record GHSA-r5fx-8r73-v86c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-14863

Advisory: AngularJS Cross-site Scripting due to failure to sanitize `xlink.href` attributes
IDs: CVE-2019-14863, GHSA-r5fx-8r73-v86c
Record: https://patchnext.com/advisories/cve-2019-14863 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: angular 1.5.0-beta.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm angular: affected < 1.5.0-beta.1; fixed in 1.5.0-beta.1

## Suggested inspection (read-only)
- `npm ls angular --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on angular.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r5fx-8r73-v86c (OSV record GHSA-r5fx-8r73-v86c lists affected ranges: npm angular >=0 <1.5.0-beta.1 (fixed))
- Verified: https://github.com/advisories/GHSA-r5fx-8r73-v86c (GitHub-reviewed advisory GHSA-r5fx-8r73-v86c lists affected ranges: npm angular >=0 <1.5.0-beta.1)

Commands are suggestions: review each one before running it.

Loading voting…