XSS via JQLite DOM manipulation functions in AngularJS
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (angular 1.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm angular
- Affected
- < 1.8.0
- Fixed in
- 1.8.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5cp4-xmrw-59wf lists affected ranges: npm angular >=0 <1.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5cp4-xmrw-59wf lists affected ranges: npm angular >=0 <1.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary XSS may be triggered in AngularJS applications that sanitize user-controlled HTML snippets before passing them to JQLite methods like JQLite.prepend, JQLite.after, JQLite.append, JQLite.replaceWith, JQLite.append, new JQLite and angular.element. Description JQLite (DOM manipulation library that's part of AngularJS) manipulates input HTML before inserting it to the DOM in jqLiteBuildFragment. One of the modifications performed expands an XHTML self-closing tag. If jqLiteBuildFragment is called (e.g. via new JQLite(aString)) with user-controlled HTML string that was sanitized (e.g. with DOMPurify), the transformation done by JQLite may modify some forms of an inert, sanitized payload into a payload containing JavaScript - and trigger an XSS when the payload is inserted into DOM. This is similar to a bug in jQuery htmlPrefilter function that was fixed in 3.5.0. Proof of concept Note that the style element is not closed and <img would be a text node inside the style if inserted…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5cp4-xmrw-59wf
- Revision 1 · created ·
Published from osv record GHSA-5cp4-xmrw-59wf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5cp4-xmrw-59wf Advisory: XSS via JQLite DOM manipulation functions in AngularJS IDs: GHSA-5cp4-xmrw-59wf Record: https://patchnext.com/advisories/ghsa-5cp4-xmrw-59wf (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: angular 1.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm angular: affected < 1.8.0; fixed in 1.8.0 ## Suggested inspection (read-only) - `npm ls angular --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on angular. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5cp4-xmrw-59wf (OSV record GHSA-5cp4-xmrw-59wf lists affected ranges: npm angular >=0 <1.8.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5cp4-xmrw-59wf (GitHub-reviewed advisory GHSA-5cp4-xmrw-59wf lists affected ranges: npm angular >=0 <1.8.0) Commands are suggestions: review each one before running it.
Loading voting…