Skip to content

← Public intelligence

npm package

@sentry/google-cloud-serverless

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1npmAmendedPublished

    Sentry's sensitive headers are leaked when sendDefaultPii is set to true

    CVE-2025-65944 · GHSA-6465-jgvq-jhgp

    Affected
    • npm @sentry/google-cloud-serverless >= 10.11.0, < 10.27.0
    Fixed in
    10.27.0· Vendor fix available
    Issue
    Impact In version 10.11.0, a change to how the SDK collects request data in Node.js applications caused certain incoming HTTP headers to be added as trace span attributes. When sendDefaultPii: true was set, a few headers that were previously redacted - including Authorization and Cookie - were unintentionally allowed through. Sentry’s server-side scrubbing (handled by Sentry's Relay edge proxy) normally serves as a second layer of protection. However, because it relied on the same matching logic as the SDK, it also failed to catch these headers in this case. Users may be impacted if: 1. Their Sentry SDK configuration has sendDefaultPii set to true 2. Their application uses one of the Node.js Sentry SDKs with version from 10.11.0 to 10.26.0 inclusively: - @sentry/astro - @sentry/aws-serverless - @sentry/bun - @sentry/google-cloud-serverless - @sentry/nestjs - @sentry/nextjs - @sentry/node - @sentry/node-core - @sentry/nuxt - @sentry/remix - @sentry/solidstart - @sentry/sveltekit Users…

    Recommended action: Upgrade to 10.27.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Low, CVSS 3.7npmAmendedPublished

    Potential DoS when using ContextLines integration

    GHSA-r5w7-f542-q2j4

    Affected
    • npm @sentry/google-cloud-serverless >= 8.10.0, < 8.49.0
    Fixed in
    8.49.0· Vendor fix available
    Issue
    Impact The ContextLines integration uses readable streams to more efficiently use memory when reading files. The ContextLines integration is used to attach source context to outgoing events. The stream was not explicitly closed after use. This could lead to excessive amounts of file handles open on the system and potentially lead to a Denial of Service (DoS). The ContextLines integration is enabled by default in the Node SDK (@sentry/node) and SDKs that run in Node.js environments (@sentry/astro, @sentry/aws-serverless, @sentry/bun, @sentry/google-cloud-serverless, @sentry/nestjs, @sentry/nextjs, @sentry/nuxt, @sentry/remix, @sentry/solidstart, @sentry/sveltekit). Patches Users should upgrade to version 8.49.0 or higher. Workarounds To remediate this issue in affected versions without upgrading to version 8.49.0 and above you can disable the ContextLines integration. See the docs for more details. If you disable the ContextLines integration, you will lose source context on your error…

    Recommended action: Upgrade to 8.49.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →