Skip to content

← Actionable
Low, CVSS 3.7amended

Potential DoS when using ContextLines integration

GHSA-r5w7-f542-q2j4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sentry/solidstart 8.49.0; @sentry/nextjs 8.49.0; @sentry/google-cloud-serverless 8.49.0; @sentry/bun 8.49.0; @sentry/nestjs 8.49.0; 6 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact The ContextLines integration uses readable streams to more efficiently use memory when reading files. The ContextLines integration is used to attach source context to outgoing events. The stream was not explicitly closed after use. This could lead to excessive amounts of file handles open on the system and potentially lead to a Denial of Service (DoS). The ContextLines integration is enabled by default in the Node SDK (@sentry/node) and SDKs that run in Node.js environments (@sentry/astro, @sentry/aws-serverless, @sentry/bun, @sentry/google-cloud-serverless, @sentry/nestjs, @sentry/nextjs, @sentry/nuxt, @sentry/remix, @sentry/solidstart, @sentry/sveltekit). Patches Users should upgrade to version 8.49.0 or higher. Workarounds To remediate this issue in affected versions without upgrading to version 8.49.0 and above you can disable the ContextLines integration. See the docs for more details. If you disable the ContextLines integration, you will lose source context on your error…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r5w7-f542-q2j4

  2. Revision 1 · created ·

    Published from osv record GHSA-r5w7-f542-q2j4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-r5w7-f542-q2j4

Advisory: Potential DoS when using ContextLines integration
IDs: GHSA-r5w7-f542-q2j4
Record: https://patchnext.com/advisories/ghsa-r5w7-f542-q2j4 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sentry/solidstart 8.49.0; @sentry/nextjs 8.49.0; @sentry/google-cloud-serverless 8.49.0; @sentry/bun 8.49.0; @sentry/nestjs 8.49.0; @sentry/aws-serverless 8.49.0; @sentry/nuxt 8.49.0; @sentry/sveltekit 8.49.0; @sentry/remix 8.49.0; @sentry/node 8.49.0; @sentry/astro 8.49.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sentry/solidstart: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/nextjs: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/google-cloud-serverless: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/bun: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/nestjs: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/aws-serverless: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/nuxt: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/sveltekit: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/remix: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/node: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0
- npm @sentry/astro: affected >= 8.10.0, < 8.49.0; fixed in 8.49.0

## Suggested inspection (read-only)
- `npm ls @sentry/solidstart --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/nextjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/google-cloud-serverless --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/bun --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/nestjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/aws-serverless --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/nuxt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/sveltekit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/remix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/astro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sentry/solidstart, @sentry/nextjs, @sentry/google-cloud-serverless, @sentry/bun, @sentry/nestjs, @sentry/aws-serverless, @sentry/nuxt, @sentry/sveltekit, @sentry/remix, @sentry/node, @sentry/astro.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r5w7-f542-q2j4 (OSV record GHSA-r5w7-f542-q2j4 lists affected ranges: npm @sentry/node >=8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 <8.49.0 (fixed); npm @sentry/solidstart…)
- Verified: https://github.com/advisories/GHSA-r5w7-f542-q2j4 (GitHub-reviewed advisory GHSA-r5w7-f542-q2j4 lists affected ranges: npm @sentry/node >=8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 =8.10.0 <8.49.0)

Commands are suggestions: review each one before running it.

Loading voting…