Skip to content

← Actionable
Medium, CVSS 5.1amended

Sentry's sensitive headers are leaked when sendDefaultPii is set to true

CVE-2025-65944GHSA-6465-jgvq-jhgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sentry/solidstart 10.27.0; @sentry/nextjs 10.27.0; @sentry/google-cloud-serverless 10.27.0; @sentry/bun 10.27.0; @sentry/nestjs 10.27.0; 7 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:L · score source
EPSS
  • CVE-2025-65944: 0.37% estimated exploitation activity in the next 30 days; percentile 30.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In version 10.11.0, a change to how the SDK collects request data in Node.js applications caused certain incoming HTTP headers to be added as trace span attributes. When sendDefaultPii: true was set, a few headers that were previously redacted - including Authorization and Cookie - were unintentionally allowed through. Sentry’s server-side scrubbing (handled by Sentry's Relay edge proxy) normally serves as a second layer of protection. However, because it relied on the same matching logic as the SDK, it also failed to catch these headers in this case. Users may be impacted if: 1. Their Sentry SDK configuration has sendDefaultPii set to true 2. Their application uses one of the Node.js Sentry SDKs with version from 10.11.0 to 10.26.0 inclusively: - @sentry/astro - @sentry/aws-serverless - @sentry/bun - @sentry/google-cloud-serverless - @sentry/nestjs - @sentry/nextjs - @sentry/node - @sentry/node-core - @sentry/nuxt - @sentry/remix - @sentry/solidstart - @sentry/sveltekit Users…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6465-jgvq-jhgp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6465-jgvq-jhgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65944

Advisory: Sentry's sensitive headers are leaked when `sendDefaultPii` is set to `true`
IDs: CVE-2025-65944, GHSA-6465-jgvq-jhgp
Record: https://patchnext.com/advisories/cve-2025-65944 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sentry/solidstart 10.27.0; @sentry/nextjs 10.27.0; @sentry/google-cloud-serverless 10.27.0; @sentry/bun 10.27.0; @sentry/nestjs 10.27.0; @sentry/node-core 10.27.0; @sentry/aws-serverless 10.27.0; @sentry/nuxt 10.27.0; @sentry/sveltekit 10.27.0; @sentry/remix 10.27.0; @sentry/node 10.27.0; @sentry/astro 10.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sentry/solidstart: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/nextjs: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/google-cloud-serverless: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/bun: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/nestjs: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/node-core: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/aws-serverless: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/nuxt: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/sveltekit: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/remix: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/node: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0
- npm @sentry/astro: affected >= 10.11.0, < 10.27.0; fixed in 10.27.0

## Suggested inspection (read-only)
- `npm ls @sentry/solidstart --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/nextjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/google-cloud-serverless --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/bun --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/nestjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/node-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/aws-serverless --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/nuxt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/sveltekit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/remix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sentry/astro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sentry/solidstart, @sentry/nextjs, @sentry/google-cloud-serverless, @sentry/bun, @sentry/nestjs, @sentry/node-core, @sentry/aws-serverless, @sentry/nuxt, @sentry/sveltekit, @sentry/remix, @sentry/node, @sentry/astro.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6465-jgvq-jhgp (OSV record GHSA-6465-jgvq-jhgp lists affected ranges: npm @sentry/node >=10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 <10.27.0 (fixed);…)
- Verified: https://github.com/advisories/GHSA-6465-jgvq-jhgp (GitHub-reviewed advisory GHSA-6465-jgvq-jhgp lists affected ranges: npm @sentry/node >=10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 =10.11.0 <10.27.0; npm…)

Commands are suggestions: review each one before running it.

Loading voting…