Skip to content

← Public intelligence

npm package

@payloadcms/next

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Payload: Untrusted redirect URL parameter exploit

    CVE-2026-105846 · GHSA-w84c-53h3-mc2g

    Affected
    • npm @payloadcms/next >= 3.31.0, < 3.88.0; >= 4.0.0-canary.0, < 4.0.0-canary.27
    Fixed in
    3.88.04.0.0-canary.27· Vendor fix available
    Issue
    Impact Under certain conditions, an attacker can craft a redirect link that sends a guest user to an untrusted destination after authenticating. Patches Users should upgrade Payload packages to = 3.88.0 or = 4.0.0-canary.27. Workarounds Upgrading is recommended. Until then, remove user-controlled redirect values from authentication flows or restrict them to known local paths.

    Recommended action: Upgrade to 4.0.0-canary.27 (pre-release) or 3.88.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  2. High, CVSS 8.7npmAmendedPublished

    @payloadcms/next has Stored XSS in Admin Panel

    CVE-2026-34748 · GHSA-mmxc-95ch-2j7c

    Affected
    • npm @payloadcms/next < 3.78.0
    Fixed in
    3.78.0· Vendor fix available
    Issue
    Impact A stored Cross-site Scripting (XSS) vulnerability existed in the admin panel. An authenticated user with write access to a collection could save content that, when viewed by another user, would execute in their browser. Consumers are affected if ALL of these are true: - Payload version < v3.78.0 - At least one collection with versions enabled - An authenticated user has create or update access to that collection Patches This vulnerability has been patched in v3.78.0. Output encoding has been added to prevent user-supplied content from being interpreted as markup. Users should upgrade to v3.78.0 or later. Workarounds If consumers cannot upgrade immediately: - Restrict create and update access to versioned collections to trusted roles only.

    Recommended action: Upgrade to 3.78.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.3npmAmendedPublished

    Payload does not invalidate JWTs after log out

    CVE-2025-4643 · GHSA-5v66-m237-hwf7

    Affected
    • npm @payloadcms/next < 3.44.0
    Fixed in
    3.44.0· Vendor fix available
    Issue
    Payload uses JSON Web Tokens (JWT) for authentication. After log out JWT is not invalidated, which allows an attacker who has stolen or intercepted token to freely reuse it until expiration date (which is by default set to 2 hours, but can be changed). This issue has been fixed in version 3.44.0 of Payload.

    Recommended action: Upgrade to 3.44.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.3npmAmendedPublished

    Payload's SQLite adapter Session Fixation vulnerability

    CVE-2025-4644 · GHSA-26rv-h2hf-3fw4

    Affected
    • npm @payloadcms/next < 3.44.0
    Fixed in
    3.44.0· Vendor fix available
    Issue
    A Session Fixation vulnerability existed in Payload's SQLite adapter due to identifier reuse during account creation. A malicious attacker could create a new account, save its JSON Web Token (JWT), and then delete the account, which did not invalidate the JWT. As a result, the next newly created user would receive the same identifier, allowing the attacker to reuse the JWT to authenticate and perform actions as that user. This issue has been fixed in version 3.44.0 of Payload.

    Recommended action: Upgrade to 3.44.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →